cht電腦資訊gcingcin分享
adm Find login register

Ubuntu 18.04/16.04/…/12.04 安裝最新的 gcin 中文輸入的完整步驟

eliu

joined: 2007-08-09
posted: 11332
promoted: 612
bookmarked: 185
新竹, 台灣
31subject: Promote 0 Bookmark 02014-04-23quote  

你是用什麼AP

guest
32subject: Promote 0 Bookmark 02014-04-23quote  

不好意思,請問AP指的是?

 

eliu

joined: 2007-08-09
posted: 11332
promoted: 612
bookmarked: 185
新竹, 台灣
33subject: Promote 0 Bookmark 02014-04-23quote  

在什麼應用程式使用 gcin

guest
34subject: Promote 0 Bookmark 02014-04-24quote  

libreoffice、chrome等一般常用的程式都是如此,還沒有例外的

eliu

joined: 2007-08-09
posted: 11332
promoted: 612
bookmarked: 185
新竹, 台灣
35subject: Promote 0 Bookmark 02014-04-24quote  

有用 gcin-tools 改到中英切換鍵?內定就是 ctrl-space.你是用 Ubuntu Unity(Ubuntun內定的) 或是其他的桌面環境 desktop?

guest
36subject: Promote 0 Bookmark 02014-04-25quote  

我的gcin-tools

內定輸入法~輸入視窗切換 設定是ctrl+space沒錯

不過完全起步了作用

改成windows+space就可以順利切換

是我鍵盤設定的問題嘛?

eliu

joined: 2007-08-09
posted: 11332
promoted: 612
bookmarked: 185
新竹, 台灣
37subject: Promote 0 Bookmark 02014-04-28quote  

懷疑你是不是透過 Cygwin/X 使用 gcin?Cygwin/X 的確有這個問題,不過這不是 gcin 的問題。

guest
38subject: Promote 0 Bookmark 02014-04-28quote  

我找到問題的所在了

ubuntu 內建語言設定裏頭

有一個切換設定快捷鍵變成ctrl+space

這個設定跟gcin互相衝突

改成win+space

就可以成功召喚gcin了

guest
39subject: Promote 0 Bookmark 02014-05-06quote  

gcin 在 gnome3.12 (ubuntu 14.04) 

輸入  常常會卡住 

eliu

joined: 2007-08-09
posted: 11332
promoted: 612
bookmarked: 185
新竹, 台灣
40subject: Promote 0 Bookmark 02014-05-06quote  

用了一下 gnome, gnome classic,還是一樣難用,比 unity 更難用。gcin 可以用,但是不會顯示 gcin icon。

gnome flashback 勉強堪用,但是不喜歡那個兩條 bar 的設計,也沒辦法更改。gcin 在 gnome flashback 必須改成 gtk 雙圖示才會顯示 gcin icon。

edited: 2
guest
41subject: 目前用Mint 17,在chromium裡gcin不能正常使用Promote 0 Bookmark 02014-06-02quote  

在chromium Version 34.0.1847.116 Built on Ubuntu 14.04, running on LinuxMint 17 aura (260972)

用ctrl_space切換gcin輸入法會被強制切回En。

在其他軟體如pcmanx、firefox、libreoffice、gnome-terminal或是chrome(最新版)裡都無此問題。

如果執行gcin-setup會有anthy-module.so的錯誤訊息。

請問該如何改善呢?謝謝

eliu

joined: 2007-08-09
posted: 11332
promoted: 612
bookmarked: 185
新竹, 台灣
42subject: 目前用Mint 17,在chromium裡gcin不能正常使用Promote 0 Bookmark 02014-06-03quote  

guest
在chromium Version 34.0.1847.116 Built on Ubuntu 14.04, running on LinuxMint 17 aura (260972)

我用 Ubuntu 14.04 64-bit 的 chromium 測試沒有你說的問題。

guest
43subject: gcin-tools 沒有 Unity Indicator 選項Promote 0 Bookmark 02014-06-14quote  

你好,我的 gcin 是 2.7.6.1 在 Ubuntu 14.04 下直接用 apt-get install 安裝,

為了解決 14.04 default 沒有快速開關中英文的 hot key,所以我試了 gcin,

現在可以用 ctrl + space 開關 gcin 了,但是右上角的 indicator icon 沒有跟著輸入法切換而切換,

有照您的方法試著在 gcin-tools 下找 Unity Indicator 選項,但我沒看到,只看到一個沒有說明的格子,

不知是不是就是您說的那個選項,但打勾它之後沒有作用。

 

Indicator 沒有跟著變換。

eliu

joined: 2007-08-09
posted: 11332
promoted: 612
bookmarked: 185
新竹, 台灣
44subject: Promote 0 Bookmark 02014-06-14quote  

14.04 必須使用 第一篇的安裝最新的 gcin 2.8.2,舊版應該沒辦法顯示。indicator 的選擇在你說的畫面的「雙圖示」,改成下拉式的選單。

edited: 1
guest
45subject: 目前用Mint 17,在chromium裡gcin不能正常使用Promote 0 Bookmark 02014-06-14quote  
guest

在chromium Version 34.0.1847.116 Built on Ubuntu 14.04, running on LinuxMint 17 aura (260972)

用ctrl_space切換gcin輸入法會被強制切回En。

在其他軟體如pcmanx、firefox、libreoffice、gnome-terminal或是chrome(最新版)裡都無此問題。

如果執行gcin-setup會有anthy-module.so的錯誤訊息。

請問該如何改善呢?謝謝

我跟這位網友也有完全一樣的問題發生,一樣是Linux Mint 17,Chromium版本也是34.0.1847.116,但印象中在Linux Mint 16時一樣的版本號則沒有發生問題,我懷疑到Mint 17被更換為Aura所以產生影響,但不知道是否要等軟體中心重新編譯Chromium或者gcin方面就可修正?
guest
46subject: 請教 Cannot open /usr/share/gcin/table/@.kbmPromote 0 Bookmark 02014-06-18quote  

要測試,所以在 VirtualBox 4.3/ Ubuntu 14.04 64-bit 下安裝gcin, click "切到舊的注音鍵盤"之後,每次按Ctrl-Space人就出現如下:

Cannot open /usr/share/gcin/table/@.kbm2的Alter Message,重新安裝亦不行,請教要如何做呢?

 

 

guest
47subject: 請教 Cannot open /usr/share/gcin/table/@.kbmPromote 0 Bookmark 02014-06-18quote  

guest

要測試,所以在 VirtualBox 4.3/ Ubuntu 14.04 64-bit 下安裝gcin, click "切到舊的注音鍵盤"之後,每次按Ctrl-Space人就出現如下:

Cannot open /usr/share/gcin/table/@.kbm2的Alter Message,重新安裝亦不行,請教要如何做呢?

 

Soory! 重新安裝時我沒將.gcin目錄移除,經移除然後重新gcin-tools 就可以了

guest
48subject: 目前用Mint 17,在chromium裡gcin不能正常使用Promote 0 Bookmark 02014-07-01quote  
guest
我跟這位網友也有完全一樣的問題發生,一樣是Linux Mint 17,Chromium版本也是34.0.1847.116,但印象中在Linux Mint 16時一樣的版本號則沒有發生問題,我懷疑到Mint 17被更換為Aura所以產生影響,但不知道是否要等軟體中心重新編譯Chromium或者gcin方面就可修正?
去軟體管理員(mintInstall)裡把Qt4, GTK3都裝起來,應該就可以在Chromium裡正常切換gcin的輸入法,但即便如此在軟體管理員的搜尋欄裡仍是無法輸入中文。
guest
49subject: Failed attempt: gcin on Debian 7 LXDEPromote 0 Bookmark 02014-12-05quote  

I am on debian 7 lxde, and while I did use the steps above to install gcin, unfortunately it simply just doesn't work. 

Previously I had tried installing both fcitx, but fcitx could only produce 1) a little tiny input method identification box with the following indicators:

  1) a penguin

  2) "pinyin" symbol

  3) virtual keyboard

  4) traditional/simplified

  5) punctuation (half or full),

  6) black box

When left clicking on the keyboard symbol located in the bottom panel(lxpanel), an all-black box appears.  This doesn't allow for configuration.  Moreover when switching from English to Chinese and starting to type in pinyin the same all black box would appear where one would usually get a text selection box with 9 characters to choose from.

After fcitx failed to install, I tried ibus, and this wouldn't produce any kind of result at all.

I changed my config in Start button | preferences | Input Method and then move the selection to gcin, but the fcitx input is still the only input method, even when I start the program gcin from Start button | preferences | gcin Tools.

Anything I can do to make this work?

Andrew

afc888ny@yahoo.com

eliu

joined: 2007-08-09
posted: 11332
promoted: 612
bookmarked: 185
新竹, 台灣
50subject: Promote 0 Bookmark 02014-12-05quote  

上面的 .deb 是給 Ubuntu 用的 

Debian 可以參考 gcin-deb-for-debian-testing, 我沒有實際用過。

eliu

joined: 2007-08-09
posted: 11332
promoted: 612
bookmarked: 185
新竹, 台灣
51subject: Ubuntu 14.04/13.10/13.04/12.10/12.04 安裝最新的 gcin 中文輸入的完整步驟Promote 0 Bookmark 02014-12-27quote  

eliu
如果是用 Unity,還需要需要執行&設定 gcin-tools→外觀設定→面板狀態→Unity Indicator

最新的版本已經改成內定是 Unity Indicator 了

Kai
joined: 2015-01-05
posted: 3
promoted:
bookmarked:
52subject: Ubuntu 14.04/13.10/13.04/12.10/12.04 安裝最新的 gcin 中文輸入的完整步驟Promote 0 Bookmark 02015-01-05quote  

eliu

$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 835AB0E3

luffy@luffy-UbuntuV1204:~$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 835AB0E3
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.L1qkDZFefS --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv-keys 835AB0E3
gpg: requesting key 835AB0E3 from hkp server keyserver.ubuntu.com

gpg: keyserver timed out
gpg: keyserver receive failed: keyserver error
luffy@luffy-UbuntuV1204:~$

Is the keyserver closed?

thx.

eliu

joined: 2007-08-09
posted: 11332
promoted: 612
bookmarked: 185
新竹, 台灣
53subject: Promote 0 Bookmark 02015-01-05quote  

I just tried it. It's ok now.

Kai
joined: 2015-01-05
posted: 3
promoted:
bookmarked:
54subject: Promote 0 Bookmark 02015-01-05quote  

eliu

I just tried it. It's ok now.

I still get that message now, is this my problem?

I am sure network no question, it can go to any website. 

Should I set something?

eliu

joined: 2007-08-09
posted: 11332
promoted: 612
bookmarked: 185
新竹, 台灣
55subject: Promote 0 Bookmark 02015-01-05quote  

Some of your outgoing ports are blocked. 

Try this

gcin.asc download

sudo apt-key add gcin.asc

Kai
joined: 2015-01-05
posted: 3
promoted:
bookmarked:
56subject: Promote 0 Bookmark 02015-01-05quote  

eliu

Some of your outgoing ports are blocked. 

Try this

gcin.asc download

sudo apt-key add gcin.asc

感謝你的幫忙, 已安裝並使用了

guest
57subject: Linux Mint 17.1 with Cinnamon 2.4.5Promote 0 Bookmark 02015-04-03quote  

安安,我所使用的環境是 Linux Mint 17.1 with Cinnamon 2.4.5,

GCIN真的好用,且絕大多數應用軟體都能正常運作,

但是就是有少數軟體如 Firefox 37 沒辦法使用 GCIN 輸入,

之在 KDE Plasma 5 並無這樣的問題,

請大大指點下我安裝GCIN可能是哪裡出問題了?

eliu

joined: 2007-08-09
posted: 11332
promoted: 612
bookmarked: 185
新竹, 台灣
58subject: Linux Mint 17.1 with Cinnamon 2.4.5Promote 0 Bookmark 02015-04-03quote  

guest
但是就是有少數軟體如 Firefox 37 沒辦法使用 GCIN 輸入

我用 Ubuntu 14.04 & 14.10 的 firefox 37 都 ok,用 chrome ok 嗎?firefox & chrome 目前都是 gtk2。

如果是用第1篇的安裝,gtk2 應該會自動安裝正確。或是參考

Linux/X window gcin 無法使用的檢查事項 

guest
59subject: Linux Mint 17.1 with Cinnamon 2.4.5Promote 0 Bookmark 02015-04-03quote  

eliu

 

我用 Ubuntu 14.04 & 14.10 的 firefox 37 都 ok,用 chrome ok 嗎?firefox & chrome 目前都是 gtk2。

如果是用第1篇的安裝,gtk2 應該會自動安裝正確。或是參考

Linux/X window gcin 無法使用的檢查事項 

Chrome 沒問題,我先照著文章弄弄看,感謝

ringle123
joined: 2015-04-22
posted: 3
promoted:
bookmarked:
60subject: Ubuntu 14.04/LXDE 無法執行 gcinPromote 0 Bookmark 02015-04-22quote  

已經花了三個晚上的時間 try&error 了,怎樣就是無法順利執行 gcin 在我的 Ubuntu 14.04 + LXDE 桌面系統 (已改為中文環境)。 :(

我在 Vmware 環境下所安裝的 Lubuntu 14.04 就可以很順利執行 gcin,但唯獨上述的系統環境,我重裝了五次結果仍然一樣。

最大的問題就是,當安裝好 gcin 執行它時,也把面板狀態改為 GTK 雙圖示,但只要點擊半/全型圖示,gcin 馬上消失不見,察看 process id 也已經不見了,即使重新透過 gcin-tools 設定啟動,再執行上述狀況,問題仍一樣;更不用說完全無法按 Ctrl-Space 或 Ctal-Alt-數字鍵等使用如注音等輸入法。

這個文章我也看過: http://hyperrate.com/thread.php?tid=24392

但似乎已經太久沒有更新,後述的 gtk-query-immdoules-* 也沒有這樣的指令可以測試。

唯一的症狀就是當我透過 pgrep gcin 察看 XWindow 並沒有載入 gcin 時,我直接透過 Terminal 視窗執行 gcin 但完全沒有任何回應。

另外關於 im-switch 或是 im-config 等輸入法設定,我也反覆都試過,確定預設輸入法為 gcin。

我實在已經不知道該如何檢查到底是哪裡出了問題!! 弄得很真有些灰心。

請問作者您是否可以再指點下,該如何檢查偵錯呢?

prev,1,2,3,4,9,next

cht電腦資訊gcingcin分享
adm Find login register
views:401794