cht電腦資訊gcingcin分享
adm Find login register

Ubuntu 16.04/15.10/15.04/14.10/14.04/…/12.04 安裝最新的 gcin 中文輸入的完整步驟

danjiun
joined: 2015-08-05
posted: 17
promoted:
bookmarked:
91subject: Promote 0 Bookmark 02015-08-07quote  

Hi Eliu.

我要問是不是你知到在哪裡我可以找到資料關於 Linux - im-config - Qt - gcin 跟他們的關係 ?

我要試試解決這個問題 (有一些Qt5 程式可以用gcin, 有一些Qt5程式沒用到gcin).

謝謝. Daniel

eliu

joined: 2007-08-09
posted: 10911
promoted: 593
bookmarked: 184
新竹, 台灣
92subject: Promote 0 Bookmark 02015-08-07quote  

可以用這個方法確認有沒有載入 gcin qt5

$ pgrep kate
16860

$ lsof -p 16860 | grep gcin
kate 16860 xxx mem REG 8,1 35632 5114730 /usr/lib/x86_64-linux-gnu/qt4/plugins/inputmethods/im-gcin.so
kate 16860 xxx mem REG 8,1 18664 4721108 /usr/lib/x86_64-linux-gnu/gcin/libgcin-im-client.so.1.2.5
kate 16860 xxx mem REG 8,1 14608 5114675 /usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-gcin.so

這是 15.04 的 kate,所以還是用 qt4 的,kate 不知為何 load gtk im

guest
93subject: gcin 打不出中文Promote 0 Bookmark 02015-08-23quote  

不好意思
我是裝  ubuntu14.04
也按照安裝方法

$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 835AB0E3
$ software-properties-gtk 

到 Other software (其他軟體) → Add(新增)
去裝gcin  但是一直打不出中文
我按super+空白 右上方的小框框會t從en變成ch但是一直打不出中文

eliu

joined: 2007-08-09
posted: 10911
promoted: 593
bookmarked: 184
新竹, 台灣
94subject: Promote 0 Bookmark 02015-08-23quote  

有執行底下的步驟嗎?

執行 /usr/bin/gnome-language-selector→鍵盤輸入法系統→gcin

登出&登入

guest
95subject: Promote 0 Bookmark 02015-08-23quote  

有的 而且我從裝gcin好幾次了
也用過從軟體中心裝
謝謝大大回覆

eliu

joined: 2007-08-09
posted: 10911
promoted: 593
bookmarked: 184
新竹, 台灣
96subject: Promote 0 Bookmark 02015-08-23quote  

如果系統沒有亂改,試試新增使用者然後執行 gnome-language-selector…,看是否是account的問題。

danjiun
joined: 2015-08-05
posted: 17
promoted:
bookmarked:
97subject: Promote 0 Bookmark 02015-09-05quote  

Eliu, 我都成功用gcin 在幾個程式: Texmaker , ...

它們是Qt5 (based) 程式.

可是我自己做的程式VocabularyMem, 還沒有辦法用gcin. 也不行用IBus. 所以我覺得這個程式少什麼的.

有沒有人知到少什麼?

VocabularyMem 也是Qt5 的程式。最近我發現,要set QT::WA_InputMethodEnabled, 可是還是不夠.

可能要問Qt 的人,可是謝謝任何的幫助.

Daniel

eliu

joined: 2007-08-09
posted: 10911
promoted: 593
bookmarked: 184
新竹, 台灣
98subject: Promote 0 Bookmark 02015-09-05quote  

我不熟 qt5,qt5 裏面應該有 example,或是 kate?

danjiun
joined: 2015-08-05
posted: 17
promoted:
bookmarked:
99subject: Promote 0 Bookmark 02015-09-05quote  

謝謝 Eliu, 本來我已經有texmaker 可以用。可是現在我也可以試試Kate. Ubuntu 14.04 好像還是舊的Qt4 的程式,所以我會分開的下載。我的主意是下載source code, 以後 compile, 測試 (test). 以後拿掉越來越code,到最簡單的狀況。我找到原因我告訴你。Daniel

danjiun
joined: 2015-08-05
posted: 17
promoted:
bookmarked:
100subject: Promote 0 Bookmark 02015-09-06quote  

Hi Eliu. 我只是要告訴你,可能我想錯,因為好像Ubuntu14.4 的texmaker 是Qt4 的程式,還有Linux Mint 17.2 (我用的系統) 是Ubuntu 14.4. 剛剛我還檢查 : "ldd texmaker" : 結果真的是Qt4 的程式. 我已經有拿那個source code 可是沒有成功compile (用Qt5 的) 來測試.

greatings, Daniel

danjiun
joined: 2015-08-05
posted: 17
promoted:
bookmarked:
101subject: Promote 0 Bookmark 02015-09-07quote  

Hi Eliu. 好像問題是滿大的,那個Qt5 的事情。我試過先看 :

http://www.kdab.com/qt-input-method-depth/

後來弄 :

http://www.kdab.com/qt-input-method-virtual-keyboard/

可是不知到位什麼這個keyboard 也沒半法用。可是好像那個人成功,所以還是有什麼不一樣在系統的設定.

我也發現新的 Kate 也不是完全Qt5 的程式,有Qt4Gui. 剛剛我檢查texmaker 在Suse 13.2 : 再網路寫他們的是Qt5,可是不可能是完全Qt5,因為ldd texmaker 寫 : libQtGui.so.4, 所以也是Qt4.

我不知到有沒有一個Qt5 的程式可以寫中文. 我會寄續找方法. Daniel

danjiun
joined: 2015-08-05
posted: 17
promoted:
bookmarked:
102subject: Promote 0 Bookmark 02015-09-09quote  

Hi Eliu.

我現在終於找到,可能是那個問題。

你記得我說最近我試試用一個簡單的plugin ("vkim"), 是一個virtual keyboard. 我知前沒有成功可以用這個keyboard, 可是我解釋事情給"author", 我們改一個 line :

從 :

Q_PLUGIN_METADATA(IID "org.qt-project.Qt.QPlatformInputContextFactoryInterface" FILE "vkim.json")

Q_PLUGIN_METADATA(IID "org.qt-project.Qt.QPlatformInputContextFactoryInterface.5.1" FILE "vkim.json")

現在終於那個keyboard 出現. 可能是因為我用的是Qt5.5. 成功。

所以我看你的gcin-plugin 的 source-code, 也寫

Q_PLUGIN_METADATA(IID "org.qt-project.Qt.QPlatformInputContextFactoryInterface" FILE "gcin.json")

所以我等一下要試試換到 :

Q_PLUGIN_METADATA(IID "org.qt-project.Qt.QPlatformInputContextFactoryInterface.5.1" FILE "gcin.json")

看看怎麼樣,我先要compile gcin-plugin. 看看現在有沒有運氣.

greatings, Daniel

danjiun
joined: 2015-08-05
posted: 17
promoted:
bookmarked:
103subject: Promote 0 Bookmark 02015-09-09quote  

Hi Eliu.

我要compile "gcin..." , 所以在第一步, ./configure,我有問題,他寫 :

testing if you have qt5 support
-> No, you don't have. It's ok if you don't want Qt5 immodule.

有什麼辦法呢?

兩邊我安裝Qt, as a "user" (到 /home/daniel/Qt) and with "sudo" (到 /opt/Qt) 可是還是./configure 找不到.

我也寫在 "~/.bashrc : "QTDIR=/home/daniel/Qt". 所以以又,login 以後 QTDIR 真的是這樣.

寫寫你的幫忙. Daniel

danjiun
joined: 2015-08-05
posted: 17
promoted:
bookmarked:
104subject: Promote 0 Bookmark 02015-09-17quote  

Hi Eliu and friends.

I succeed partially using Qt5 programs with gcin. 我有一點成功

I write this for more information for another people which can be in a same situation.

First at all, i discover about how we can know, why "gcin"-plugin is not loaded. A way is :

export QT_DEBUG_PLUGINS=1

./program_to_execute

This give me a definive help, what more is happen :

After loading "libgcinplatforminputcontextplugin.so" he cannot found "libgcin-im-client.so.1" which is in another directory as my Qt-folder, ... I success partially after copying folder "gcin" from "/usr/lib/x86_64-linux-gnu" to a folder of executable.

不好意思我剛剛用英文,我忘記再這個forum 寫中文。

祝你們好, Daniel

guest
105subject: Promote 0 Bookmark 02015-12-12quote  

eliu

如果系統沒有亂改,試試新增使用者然後執行 gnome-language-selector…,看是否是account的問題。

My ubuntu 14.04 is same as the above user and can't input Chinese after I finish the suggest procedule.

Then I create another account it works.

How can I repair the old account to input Chinese? Thank you very much.

eliu

joined: 2007-08-09
posted: 10911
promoted: 593
bookmarked: 184
新竹, 台灣
106subject: Promote 0 Bookmark 02015-12-12quote  

guest
My ubuntu 14.04 is same as the above user and can't input Chinese after I finish the suggest procedule.

Then I create another account it works.

How can I repair the old account to input Chinese? Thank you very much.

可能是某個 startup 設定/script 被改壞了.  在不同的 account 的 terminal 執行 env 看看環境變數有什麼不同。

guest
107subject: Promote 0 Bookmark 02015-12-13quote  

eliu

 

可能是某個 startup 設定/script 被改壞了.  在不同的 account 的 terminal 執行 env 看看環境變數有什麼不同。

謝謝您的答覆,以下的帳號是可以輸入中文的

LANGUAGE=zh_TW:en_US:en
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
UPSTART_INSTANCE=
UPSTART_EVENTS=started starting
LOGNAME=test
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-dDy9sxLZuv
XDG_DATA_DIRS=/usr/share/ubuntu:/usr/share/gnome:/usr/local/share/:/usr/share/
QT4_IM_MODULE=xim
LESSOPEN=| /usr/bin/lesspipe %s
TEXTDOMAIN=im-config
INSTANCE=Unity
UPSTART_JOB=unity-settings-daemon
XDG_RUNTIME_DIR=/run/user/1001
DISPLAY=:0
XDG_CURRENT_DESKTOP=Unity
GTK_IM_MODULE=ibus
LESSCLOSE=/usr/bin/lesspipe %s %s
LC_TIME=zh_TW.UTF-8
TEXTDOMAINDIR=/usr/share/locale/
LC_NAME=zh_TW.UTF-8
XAUTHORITY=/home/test/.Xauthority
COLORTERM=gnome-terminal
_=/usr/bin/env
test@jack-MS-7142:~$

以下的帳號是不能輸入中文

LANGUAGE=zh_TW:en_US:en
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
UPSTART_INSTANCE=
UPSTART_EVENTS=started starting
LOGNAME=jack
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-ItUM6Q3NMz
XDG_DATA_DIRS=/usr/share/ubuntu:/usr/share/gnome:/usr/local/share/:/usr/share/
QT4_IM_MODULE=xim
LESSOPEN=| /usr/bin/lesspipe %s
INSTANCE=Unity
TEXTDOMAIN=im-config
UPSTART_JOB=unity-settings-daemon
XDG_RUNTIME_DIR=/run/user/1000
DISPLAY=:1
XDG_CURRENT_DESKTOP=Unity
GTK_IM_MODULE=gcin
LESSCLOSE=/usr/bin/lesspipe %s %s
LC_TIME=zh_TW.UTF-8
TEXTDOMAINDIR=/usr/share/locale/
LC_NAME=zh_TW.UTF-8
XAUTHORITY=/home/jack/.Xauthority
COLORTERM=gnome-terminal
_=/usr/bin/env
jack@jack-MS-7142:~$

有發現到底下這幾個不一樣

DBUS_SESSION_BUS_ADDRESS

XDG_RUNTIME_DIR

DISPLAY

GTK_IM_MODULE

請問如何更改這些設定值?再次謝謝您!

eliu

joined: 2007-08-09
posted: 10911
promoted: 593
bookmarked: 184
新竹, 台灣
108subject: Promote 0 Bookmark 02015-12-15quote  

eliu
im-config 的 file 有問題,im-config 的這種設計變成輸入法 需要 im-config support 才可以,不好的設計。

/usr/share/im-config/data/26_gcin.rc

結尾插入一行

export QT_IM_MODULE=gcin

Ubuntu 15.10 還是需要這個。

guest
109subject: Ubuntu 14.04 LTS gcin有時候會crashPromote 0 Bookmark 02016-02-23quote  

Dear Eliu,

系統使用Ubuntu 14.04 LTS,原本用ibus,輸入視窗跳來跳去,後來用fcitx注音不work, 老婆不喜歡新酷音,然後發現gcin有持續在更新,試用一下,讚!

昨天更新完,輸入英文unity indicator有出現"EN"而非"stop(紅色圈圈中間斜槓)"圖示,但偶爾切換應用程式時會當掉,當掉前unity indicator會突然出現"E/TAB"的奇怪圖示,再按輸入法切換(ctrl+space)就當掉了,系統出現gcin crash/report problem回饋機制提問...

請教一下這大概是跟甚麼有關連呢? 謝謝您!

guest
110subject: gcin 打不出中文Promote 0 Bookmark 02016-02-24quote  

guest

不好意思
我是裝  ubuntu14.04
也按照安裝方法

$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 835AB0E3
$ software-properties-gtk 

到 Other software (其他軟體) → Add(新增)
去裝gcin  但是一直打不出中文
我按super+空白 右上方的小框框會t從en變成ch但是一直打不出中文

輸入法切換鍵不能跟text entry衝突,試試看將system setting>text entry的switch source按鍵改成ctrl+alt+space之類的,不要跟gcin的設定一樣。我改完就行得通了。

guest
111subject: Promote 0 Bookmark 02016-03-15quote  

最近換到lxqt上去,平常使用都正常(browser、terminator....)

但發現用pcmanfm-qt時都無法正常叫出gcin

$ pgrep pcmanfm-qt
17370

$ lsof -p 17370 | grep gcin
pcmanfm-q 17370 huki  mem       REG                8,1     22984  6301297 /usr/lib/x86_64-linux-gnu/gcin/libgcin-im-client.so.1.2.5
pcmanfm-q 17370 huki  mem       REG                8,1     14832  6301308 /usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-gcin.so

gcin-qt5-immodule is already the newest version (2.8.4+dfsg1-2).

不過不知為他是去load gtk的im-gcin.so而不qt的

eliu

joined: 2007-08-09
posted: 10911
promoted: 593
bookmarked: 184
新竹, 台灣
112subject: Promote 0 Bookmark 02016-03-15quote  

ldd /usr/bin/pcmanfm-qt 看一下 dependency

guest
113subject: Promote 0 Bookmark 02016-03-19quote  
$ ldd /usr/bin/pcmanfm-qt
        linux-vdso.so.1 (0x00007ffc9a49d000)
        libQt5DBus.so.5 => /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5 (0x00007fde01f59000)
        libfm-qt.so.2 => /usr/lib/x86_64-linux-gnu/libfm-qt.so.2 (0x00007fde01cbe000)
        libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007fde01a9b000)
        libQt5X11Extras.so.5 => /usr/lib/x86_64-linux-gnu/libQt5X11Extras.so.5 (0x00007fde01a96000)
        libQt5Widgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5 (0x00007fde01409000)
        libQt5Gui.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5 (0x00007fde00ec0000)
        libQt5Core.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 (0x00007fde009ea000)
        libfm.so.4 => /usr/lib/x86_64-linux-gnu/libfm.so.4 (0x00007fde007a1000)
        libgio-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0 (0x00007fde0041f000)
        libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007fde001cc000)
        libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007fddffebd000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fddffb41000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fddff79d000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fddff580000)
        libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007fddff330000)
        libmenu-cache.so.3 => /usr/lib/x86_64-linux-gnu/libmenu-cache.so.3 (0x00007fddff127000)
        libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007fddfef23000)
        libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007fddfed1c000)
        libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007fddfe9d9000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fddfe6db000)
        libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 (0x00007fddfe4b4000)
        libharfbuzz.so.0 => /usr/lib/x86_64-linux-gnu/libharfbuzz.so.0 (0x00007fddfe255000)
        libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007fddfe03a000)
        libGL.so.1 => /usr/lib/x86_64-linux-gnu/libGL.so.1 (0x00007fddfdcff000)
        libicui18n.so.55 => /usr/lib/x86_64-linux-gnu/libicui18n.so.55 (0x00007fddfd89d000)
        libicuuc.so.55 => /usr/lib/x86_64-linux-gnu/libicuuc.so.55 (0x00007fddfd509000)
        libpcre16.so.3 => /usr/lib/x86_64-linux-gnu/libpcre16.so.3 (0x00007fddfd2a2000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fddfd09e000)
        librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007fddfce96000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fddfcc7f000)
        /lib64/ld-linux-x86-64.so.2 (0x000055673f1a3000)
        libdbus-glib-1.so.2 => /usr/lib/x86_64-linux-gnu/libdbus-glib-1.so.2 (0x00007fddfca58000)
        libexif.so.12 => /usr/lib/x86_64-linux-gnu/libexif.so.12 (0x00007fddfc813000)
        libgthread-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0 (0x00007fddfc610000)
        libgmodule-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0 (0x00007fddfc40c000)
        libselinux.so.1 => /lib/x86_64-linux-gnu/libselinux.so.1 (0x00007fddfc1ea000)
        libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007fddfbfd2000)
        libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007fddfbdc9000)
        libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007fddfbb59000)
        libsystemd.so.0 => /lib/x86_64-linux-gnu/libsystemd.so.0 (0x00007fddfbad2000)
        libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007fddfb823000)
        libgraphite2.so.3 => /usr/lib/x86_64-linux-gnu/libgraphite2.so.3 (0x00007fddfb5fd000)
        libnvidia-tls.so.361.28 => /usr/lib/x86_64-linux-gnu/tls/libnvidia-tls.so.361.28 (0x00007fddfb3f9000)
        libnvidia-glcore.so.361.28 => /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.361.28 (0x00007fddf976b000)
        libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007fddf9558000)
        libicudata.so.55 => /usr/lib/x86_64-linux-gnu/libicudata.so.55 (0x00007fddf7aa1000)
        liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007fddf787d000)
        libgcrypt.so.20 => /lib/x86_64-linux-gnu/libgcrypt.so.20 (0x00007fddf759c000)
        libgpg-error.so.0 => /lib/x86_64-linux-gnu/libgpg-error.so.0 (0x00007fddf7387000)
sar
joined: 2016-04-28
posted: 3
promoted:
bookmarked:
Taiwan
114subject: Promote 0 Bookmark 02016-04-29quote  

I just install the "Ubuntu Gnome 16.04", but I tried to add the the PPA and install gcin. 

I have used the im-config to switch input method to "gcin", but I can't switch the input method after reboot. 

dump the env, I  found there are something wrong with these settings.

==

XMODIFIERS=@im=ibus

QT_IM_MODULE=ibus

==

I trid to modify the /usr/share/im-config/data/26_gcin.rc and hardcode the setting to "gcin". It does not work. 

I trid to modify the ~/.xinputrc and add these setting before "run_im gcin". It does not work.

I tried to modify the /etc/X11/Xsession.d/70im-config_launch. It does not work. 

 

These two settings can't change to "gcin". Could you tell me how can I trace the flow of im-config. 

Thanks a lot.

eliu

joined: 2007-08-09
posted: 10911
promoted: 593
bookmarked: 184
新竹, 台灣
115subject: Promote 0 Bookmark 02016-04-29quote  

Ubuntu 16.04 用 gnome-language-selector 可以選 gcin 是沒問題的。唯一有問題的是 qt5 不能用。

swyear
joined: 2007-10-04
posted: 127
promoted: 4
bookmarked: 0
116subject: Promote 0 Bookmark 02016-04-29quote  

sar

I just install the "Ubuntu Gnome 16.04", but I tried to add the the PPA and install gcin. 

I have used the im-config to switch input method to "gcin", but I can't switch the input method after reboot. 

dump the env, I  found there are something wrong with these settings.

==

XMODIFIERS=@im=ibus

QT_IM_MODULE=ibus

==

I trid to modify the /usr/share/im-config/data/26_gcin.rc and hardcode the setting to "gcin". It does not work. 

I trid to modify the ~/.xinputrc and add these setting before "run_im gcin". It does not work.

I tried to modify the /etc/X11/Xsession.d/70im-config_launch. It does not work. 

 

These two settings can't change to "gcin". Could you tell me how can I trace the flow of im-config. 

Thanks a lot.

You can remove ibus to avoid the bug

https://bugzilla.novell.com/show_bug.cgi?id=853063

 

sar
joined: 2016-04-28
posted: 3
promoted:
bookmarked:
Taiwan
117subject: Promote 0 Bookmark 02016-04-30quote  

swyear

 

You can remove ibus to avoid the bug

https://bugzilla.novell.com/show_bug.cgi?id=853063

 

Unfortunately, I can't remove the ibus. If I tried to remove the ibus related package, the gnome-shell will be removed too. 

Thers is a dependency between ibus and gnome-shell. 

swyear
joined: 2007-10-04
posted: 127
promoted: 4
bookmarked: 0
118subject: Promote 0 Bookmark 02016-05-01quote  

sar

 

Unfortunately, I can't remove the ibus. If I tried to remove the ibus related package, the gnome-shell will be removed too. 

Thers is a dependency between ibus and gnome-shell. 

just remove ibus-daemon from /usr/bin/

if you don't use ibus

sar
joined: 2016-04-28
posted: 3
promoted:
bookmarked:
Taiwan
119subject: Promote 0 Bookmark 02016-05-03quote  

swyear

 

just remove ibus-daemon from /usr/bin/

if you don't use ibus

 

Thanks!

Just rename the ibus-daemon and it works.

I found other solution, but it does not work in my side. 

https://fcitx-im.org/wiki/Note_for_GNOME_Later_than_3.6

guest
120subject: Promote 0 Bookmark 02016-06-20quote  

ubuntu Xenial server + mate desktop

sudo apt-get update出現下列通知

W: http://hyperrate.com/gcin-ubuntu1510/dists/eliu/Release.gpg: Signature by key 3F1A3C3A00BA96E05789B9505C577D59835AB0E3 uses weak digest algorithm (SHA1)

prev,1,2,3,4,5,6,next

cht電腦資訊gcingcin分享
adm Find login register
views:198770