cht電腦資訊gcin
adm Find login register

ubuntu下的問題

guest
1subject: ubuntu下的問題Promote 0 Bookmark 02008-10-27quote  

各位好

我真的很喜歡GCIN

但是最近我發現在ubuntu 8.04下

我沒辦法在OPERA 9.61裡面啟動切換GCIN的中文輸入

我是設定ctrl+space來做切換

有人有類似的問題嗎?

我的GCIN版本是UBUNTU內訂的1.3.7.1

謝謝

caleb
joined: 2007-09-22
posted: 630
promoted: 134
bookmarked: 90
2subject: ubuntu下的問題Promote 0 Bookmark 02008-10-27quote  
opera 分別有 Qt3、Qt4、static、dynamic linked,請分別試用。

我以前試 opera 時,上述有些是會和輸入法相沖的。

eliu

joined: 2007-08-09
posted: 11446
promoted: 617
bookmarked: 187
新竹, 台灣
3subject: Promote 0 Bookmark 02008-10-27quote  

我用 在 Mandriva qt3 的 opera 好像沒有問題

winlin

joined: 2007-09-25
posted: 1856
promoted: 110
bookmarked: 33
4subject: Promote 0 Bookmark 02008-10-27quote  

剛剛試了一下,
我發現沒裝gcin-qt3-immodule這個套件就不能在opera 9.61用ctrl+space開啟gcin,

奇怪....opera 9.61好像不吃xim了,
看來非得多加個「export QT_IM_MODULE=gcin」才行

-------------------------------------------------------------------
好用的gcin連結:

guest
5subject: Promote 0 Bookmark 02008-10-28quote  
to caleb
請問一下哪裡可以下載您所說的那些版本呢?
我在OPERA網站上面找不到耶謝謝

to winlin,
我裝了gcin-qt3-immodule這個套件還是不行(重新開機過後也不行)
您所說的
export QT_IM_MODULE=gcin
應該加在哪個檔案裡呢?
謝謝各位
guest
6subject: Promote 0 Bookmark 02008-10-28quote  

我試過了加在

~/.bashrc

不過還是不行

caleb
joined: 2007-09-22
posted: 630
promoted: 134
bookmarked: 90
7subject: Promote 0 Bookmark 02008-10-28quote  

guest
請問一下哪裡可以下載您所說的那些版本呢?

http://get.opera.com/pub/opera/linux/961/final/en/

guest
我裝了gcin-qt3-immodule這個套件還是不行(重新開機過後也不行)

乾淨的 Ubuntu + gcin 1.3.7.1,有使用 im-switch 管理的話,安裝 gcin-qt3-immodule 重新登入就會自動啟用 Qt3 immodule

不能用的幾種可能:

1. 沒有完全使用 im-switch 管理

(Ubuntu 從古到今的輸入法管理十分混亂,時至今日中英文論壇裡仍有很多莫名其妙的輸入法錯誤設定)

2. im-switch 設定檔錯亂

(把 $HOME/.xinput.d 之類的目錄改名或刪除後重新執行 im-switch -s gcin 即可)

3. opera 可能把 QT_IM_MODULE 吃掉了

(我很久沒用 opera 了,懶得測 9.61)

 

最簡單的測試法,開一個 terminal emulator (終端機) ,然後執行

export QT_IM_MODULE=gcin

opera &

須注意,gcin 1.3.7.1 不支援 Qt4 immodule ,

1.4.3.pre5 以後版本才有。

winlin

joined: 2007-09-25
posted: 1856
promoted: 110
bookmarked: 33
8subject: Promote 0 Bookmark 02008-10-28quote  

caleb
  須注意,gcin 1.3.7.1 不支援 Qt4 immodule ,1.4.3.pre5 以後版本才有。

這裡有1.4.3.pre8,Solomon幫Debian編好的,(←感謝Solomon!)
但是,因為是免費空間,所以下載手續會比較瑣碎一點,
另外,不知道ubuntu能不能用就是了,
之前好像看到ubuntu中文站上已經有人編好pre8了,
如果想用可以搜尋看看 :)

-------------------------------------------------------------------
好用的gcin連結:

guest
9subject: Promote 0 Bookmark 02008-10-29quote  

再次感謝各位

我終於搞定了

應該是因為我的個人home目錄下面沒有

.xinput.d這個目錄

我之前就有裝了im-switch, 

現在整理一下讓以後有類似問題的人可以參考一下

1. 安裝gcin-qt3-immodule

2. 檢查個人家目錄底下是否有 .xinput.d這個目錄, 沒有的話在終端機(terminal)打上im-switch -s gcin

就會產生了(如果已經有了殺掉該目錄再執行一次im-switch -s gcin)

3. 重新啟動後應該就可以了 

4. 至於opera的版本我是直接在官網下載給ubuntu的版本(opera_9.61.2456.gcc4.qt3_i386.deb) 

 真的很感謝各位幫忙!!! 

 

cht電腦資訊gcin
adm Find login register
views:21054