cht電腦資訊gcin已解決問題
adm Find login register

現在編譯需要 X11 ,不利各大 distro 打包

caleb
joined: 2007-09-22
posted: 630
promoted: 134
bookmarked: 90
1subject: 現在編譯需要 X11 ,不利各大 distro 打包Promote 0 Bookmark 02011-09-20quote  

雖然不少 apps 編譯時也有用到 xvfb 之類的,但通常都是放在 make test 之類的可選項目,不裝 X 也沒事。

現在 gcin 在 build-time 就強制使用 X, 讓各大 distro 維護難度提高,似乎不太好?

gcin 原來就以打包困難聞名,現在又多個 xvfb 顯然是雪上加霜…

以下是 Tetralet 的血淚控訴:

make[2]: Entering directory `/tmp/build/gcin/gcin-1.6.9~pre3/data'
GCIN_NO_RELOAD=;export GCIN_NO_RELOAD;export LD_LIBRARY_PATH=../im-client;../phoa2d pho.tab2.src

(phoa2d:2877): Gtk-WARNING **: cannot open display:
make[2]: *** [pho.tab2] Error 1
make[2]: Leaving directory `/tmp/build/gcin/gcin-1.6.9~pre3/data'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/tmp/build/gcin/gcin-1.6.9~pre3'
make: *** [build-stamp] Error 2

eliu

joined: 2007-08-09
posted: 11451
promoted: 617
bookmarked: 187
新竹, 台灣
2subject: Promote 0 Bookmark 02011-09-20quote  

已經在 pre4中修正

cht電腦資訊gcin已解決問題
adm Find login register
views:4630