cht電腦資訊gcin
adm Find login register

編譯 deb 用的 gcin 1.4.3.pre8 diff

caleb
joined: 2007-09-22
posted: 630
promoted: 134
bookmarked: 90
2subject: 編譯 deb 用的 gcin 1.4.3.pre8 diffPromote 0 Bookmark 02009-11-21quote  

既然沒人用,本 diff 以後也不再更新了。

更新:既然有人用,本 diff 就更新到 kanru (debian gcin maintainer) 退伍為止吧。

edited: 6
winlin

joined: 2007-09-25
posted: 1838
promoted: 110
bookmarked: 33
3subject: 編譯 deb 用的 gcin 1.4.3.pre8 diffPromote 0 Bookmark 02008-10-22quote  

caleb
既然沒人用,本 diff 以後也不再更新了。

真的沒人用嗎?應該有吧?
其實我很想用,也下載過了,不過,在下程度實在太差,看了gcin trac上的gcin打包deb說明之後,
還是不知道這個diff檔如何運用... ,後來才索性從rpm去轉...好糗呀

-------------------------------------------------------------------
好用的gcin連結:

edited: 1
guest
4subject: Promote 0 Bookmark 02008-10-23quote  

This diff does help a lot. Thank you!

winlin

joined: 2007-09-25
posted: 1838
promoted: 110
bookmarked: 33
5subject: Promote 0 Bookmark 02008-10-23quote  
guest

This diff does help a lot. Thank you!

caleb兄,看吧↑,這可不是我去反串貼出來的喔~
麻煩您了~

-------------------------------------------------------------------
好用的gcin連結:

Solomon

joined: 2008-02-27
posted: 78
promoted: 22
bookmarked: 3
6subject: 編譯 deb 用的 gcin 1.4.3.pre8 diffPromote 1 Bookmark 02008-10-23quote  
   

caleb
既然沒人用,本 diff 以後也不再更新了。

caleb兄,有在用啦。很好用的耶。

剛剛趁著空檔用 diff 包了一下。把編好的 deb 給上傳。

 

gcin_1.4.3_pre8-1_i3860.deb  http://www.badongo.com/file/11800940
gcin-dev_1.4.3_pre8-1_all4.deb
   http://www.badongo.com/file/11800965
gcin-qt3-immodule_1.4.3_pre8-1_i386.deb
   http://www.badongo.com/file/11800985
gcin-qt4-immodule_1.4.3_pre8-1_i386.deb   http://www.badongo.com/file/11800991
gcin_1.4.3_pre8-1.tar.gz   http://www.badongo.com/file/11801008

 

gcin_1.4.3_pre8-1_i3860.deb 可能是我傳了兩次還是什麼原因,badongo多加了一個0。本來的檔名應是 gcin_1.4.3_pre8-1_i386.deb,不過應該沒有什麼關係。

 

 

 

edited: 1
guest
7subject: Promote 0 Bookmark 02008-10-27quote  

我也有在用啦...只是pre這種版本不會追的很勤...

而且我也只純粹會編譯而已...而且都會有一些小問題...

 

希望有能力的人能跳出來接手...

alan

joined: 2007-09-25
posted: 134
promoted: 7
bookmarked: 1
8subject: 編譯 deb 用的 gcin 1.4.3.pre8 diffPromote 0 Bookmark 02008-10-28quote  

Solomon兄

或許 dropbox 比badongo方便

感謝你的 deb 檔 

swyear
joined: 2007-10-04
posted: 127
promoted: 4
bookmarked: 0
9subject: Promote 0 Bookmark 02008-10-29quote  

caleb:

可否提供一個 dsc 檔

我想在 openSUSE BuildService 上試試看

我對 deb 都沒概念就是了

 

swyear
joined: 2007-10-04
posted: 127
promoted: 4
bookmarked: 0
11subject: Promote 0 Bookmark 02008-10-30quote  

 根據  http://en.opensuse.org/Build_Service/Deb_builds

修改掉

 debhelper (>= 7), libgtk2.0-dev (>= 2.10.1)

因為 OBS 都會說不提供這些

改成

debhelper (>= 4.1.16), libgtk2.0-dev

環境是 Debian_Etch

build log:

...

rm -f .depend
dh_clean
dh_clean: Sorry, but 5 is the highest compatibility level supported by this debhelper.
make: *** [clean-patched] Error 1
System halted.

最後停在這邊?不知道該如何改

需要完整的 log 嗎?

swyear
joined: 2007-10-04
posted: 127
promoted: 4
bookmarked: 0
13subject: Promote 0 Bookmark 02008-10-31quote  

瞭解了,謝謝您的協助

 

swyear
joined: 2007-10-04
posted: 127
promoted: 4
bookmarked: 0
14subject: Promote 0 Bookmark 02008-11-08quote  

果然在 Etch 上不能成功

 dh_install
LD_LIBRARY_PATH=debian/gcin/usr/lib/gcin:/usr/lib/libfakeroot:/usr/lib64/libfakeroot:/usr/lib32/libfakeroot dh_gtkmodules
/bin/sh: dh_gtkmodules: command not found
make: *** [binary-arch] Error 127

caleb 我可不是不相信您喔

我是想看看 ubuntu 可不可以而已

ubuntu 8.04 的 OBS log

 dh_install
LD_LIBRARY_PATH=debian/gcin/usr/lib/gcin:/usr/lib/libfakeroot:/usr/lib64/libfakeroot:/usr/lib32/libfakeroot dh_gtkmodules
dh_gtkmodules: skipping /usr/src/packages/BUILD/debian/gcin/usr/lib/gtk-2.0/2.10.0/loaders.
dh_installmenu
dh_link
dh_strip
dh_compress
dh_fixperms
dh_makeshlibs -n
dh_installdeb
dh_shlibdeps
dpkg-shlibdeps: warning: debian/gcin/usr/bin/phod2a shouldn't be linked with libgtk-x11-2.0.so.0 (it uses none of its symbols).
dpkg-shlibdeps: warning: debian/gcin/usr/bin/gcin-kbm-toggle shouldn't be linked with libgtk-x11-2.0.so.0 (it uses none of its symbols).
dpkg-shlibdeps: warning: debian/gcin/usr/bin/gcin-message shouldn't be linked with libgtk-x11-2.0.so.0 (it uses none of its symbols).
dpkg-shlibdeps: warning: debian/gcin/usr/bin/gtab-merge shouldn't be linked with libgtk-x11-2.0.so.0 (it uses none of its symbols).
dpkg-shlibdeps: warning: debian/gcin/usr/bin/gcin-gb-toggle shouldn't be linked with libgtk-x11-2.0.so.0 (it uses none of its symbols).
dpkg-shlibdeps: warning: debian/gcin/usr/bin/tsd2a32 shouldn't be linked with libgtk-x11-2.0.so.0 (it uses none of its symbols).
dpkg-shlibdeps: warning: debian/gcin/usr/bin/gcin2tab shouldn't be linked with libgtk-x11-2.0.so.0 (it uses none of its symbols).
dpkg-shlibdeps: warning: symbol XInternAtom used by debian/gcin/usr/lib/gcin/libgcin-im-client.so.1.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XGetWindowProperty used by debian/gcin/usr/lib/gcin/libgcin-im-client.so.1.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XGetSelectionOwner used by debian/gcin/usr/lib/gcin/libgcin-im-client.so.1.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XFree used by debian/gcin/usr/lib/gcin/libgcin-im-client.so.1.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: debian/gcin/usr/bin/tsd2a shouldn't be linked with libgtk-x11-2.0.so.0 (it uses none of its symbols).
dh_gencontrol
dpkg-gencontrol: warning: unknown substitution variable ${shlibs:Depends}
dpkg-gencontrol: warning: unknown substitution variable ${misc:Depends}
dpkg-gencontrol: warning: unknown substitution variable ${misc:Depends}
dpkg-gencontrol: warning: unknown substitution variable ${misc:Depends}
dh_md5sums
dh_builddeb
dpkg-deb: building package `gcin' in `../gcin_1.4.3~pre8-1_i386.deb'.
dpkg-deb: building package `gcin-dev' in `../gcin-dev_1.4.3~pre8-1_all.deb'.
dpkg-deb: building package `gcin-qt3-immodule' in `../gcin-qt3-immodule_1.4.3~pre8-1_i386.deb'.
dpkg-deb: building package `gcin-qt4-immodule' in `../gcin-qt4-immodule_1.4.3~pre8-1_i386.deb'.
dpkg-genchanges >../gcin_1.4.3~pre8-1_i386.changes
dpkg-genchanges: including full source code in upload
dpkg-buildpackage: full upload; Debian-native package (full source is included)
... checking for files with abuild user/group
... saving built packages
/usr/src/packages/DEBS/gcin-dev_1.4.3~pre8-1_all.deb
/usr/src/packages/DEBS/gcin-qt3-immodule_1.4.3~pre8-1_i386.deb
/usr/src/packages/DEBS/gcin-qt4-immodule_1.4.3~pre8-1_i386.deb
/usr/src/packages/DEBS/gcin_1.4.3~pre8-1_i386.deb
... build is finished
swapoff: /dev/hda2: Invalid argument
System halted.
extracting built packages...
gcin-dev_1.4.3~pre8-1_all.deb
gcin-qt3-immodule_1.4.3~pre8-1_i386.deb
gcin-qt4-immodule_1.4.3~pre8-1_i386.deb
gcin_1.4.3~pre8-1_i386.deb
3408 blocks
dd: writing `standard output': Broken pipe
3536+0 records in
3535+0 records out
1809920 bytes (1.8 MB) copied, 0.159172 seconds, 11.4 MB/s

有些 warning

但有 deb 出來了,這樣的 deb 可以(適合)用在 ubuntu 上嗎?

 

guest
17subject: Promote 0 Bookmark 02008-11-11quote  
感謝caleb大大的持續提供!
Solomon

joined: 2008-02-27
posted: 78
promoted: 22
bookmarked: 3
18subject: Promote 1 Bookmark 02008-11-12quote  

我打包之後放在以下的網頁。

謝謝 caleb 。

  http://sites.google.com/site/gcinunofficialdebs/

 

 

edited: 1
guest
19subject: Promote 0 Bookmark 02008-11-12quote  

用 caleb 提供的 diff 和 openSUSE Build Service (OBS) 編譯出來的 gcin-deb  for ubuntu 8.04 和 7.10

8.04

 http://download.opensuse.org/repositories/home:/swyear/xUbuntu_8.04/

7.10

 http://download.opensuse.org/repositories/home:/swyear/xUbuntu_7.10/

好膽的可以試用看看

 

Solomon

joined: 2008-02-27
posted: 78
promoted: 22
bookmarked: 3
21subject: Promote 1 Bookmark 02008-12-06quote  
caleb

更新到 1.4.3.pre10

注意:XIM 使用「解空白視窗」後可能會無法使用 ← 這跟本 diff 無關。

pre10 tarball 已知至少有兩個版本,差別在於:

1. Changelog.html 加上解空白視窗警語「但是 XIM 在使用後會造成無法使用的情形」

2. tsin.src 新增「吸熱 ㄒㄧ ㄖㄜ4 0」

 

已更新 pre10 的deb。

謝謝 caleb 的 patch。

 

guest
23subject: Promote 0 Bookmark 02008-12-07quote  

不知道大大能否將穩定版本和pre版的diff

放在http://www.csie.nctu.edu.tw/~cp76/gcin/download/這邊呢?

沒看到穩定版本的diff耶

先謝謝大大了

Solomon

joined: 2008-02-27
posted: 78
promoted: 22
bookmarked: 3
25subject: Promote 2 Bookmark 02008-12-09quote  

gcin非官方套件已更新至 1.4.3~pre11

謝謝 eliu 與 caleb

winlin

joined: 2007-09-25
posted: 1838
promoted: 110
bookmarked: 33
26subject: Promote 0 Bookmark 02008-12-10quote  
Solomon

gcin非官方套件已更新至 1.4.3~pre11

謝謝 eliu 與 caleb

感謝Solomon!幫你推了一個 !大笑

-------------------------------------------------------------------
好用的gcin連結:

Solomon

joined: 2008-02-27
posted: 78
promoted: 22
bookmarked: 3
28subject: unofficial 更新Promote 1 Bookmark 02008-12-13quote  
剛剛上傳了 1.4.3 pre12,有需要的朋友請更新
Tetralet

joined: 2007-11-27
posted: 255
promoted: 35
bookmarked: 13
29subject: Promote 1 Bookmark 02008-12-25quote  
這個小 patch 可以修正 gcin 在 Debian 的 IceWeasel 裡初始遊標不正確的問題。請笑納 XD
1,2,next

cht電腦資訊gcin
adm Find login register
views:34720