cht電腦資訊gcin
adm Find login register

gcin在ubuntu22.04無法正常使用

e201302012123@gmail.com
joined: 2013-05-26
posted: 116
promoted:
bookmarked:
杭州
1subject: gcin在ubuntu22.04無法正常使用Promote 0 Bookmark 02022-08-05quote  

我在新系統ubuntu22.04安裝了gcin之後,terminal都打不開,語言設置窗口也打不開。只好按ctrl+alt+f6到另個工作臺,remove掉gcin,重啟才恢復正常。

e201302012123@gmail.com
joined: 2013-05-26
posted: 116
promoted:
bookmarked:
杭州
2subject: Promote 0 Bookmark 02022-08-05quote  

試了不少辦法,比如安裝繁體中文包,還是無法正常使用gcin。

我只好去用ibus-table了。ibus-table還算挺好用。而且默認已安裝。這對gcin作者可能不是一個好消息。不過如果作者解決了這個問題,我還是會試一下。

如果有其他朋友也安裝ubuntu22.04的話可以裝gcin試一下,看是否會産生同樣問題。

eliu

joined: 2007-08-09
posted: 11444
promoted: 617
bookmarked: 187
新竹, 台灣
3subject: Promote 0 Bookmark 02022-08-07quote  

Ubuntu 22.04 的 GTK3 有問題,造成 X11 的相容性問題,gcin 有用到 X11 的部份。

像使用 ssh -X Ubuntu2204,使用 X11 forwarding。使用 X11 的 rxvt-unicode 及 QT 的 kate,都可以正常顯示。

使用 GTK 的 gnome-terminal、gedit 都無法顯示。

e201302012123@gmail.com
joined: 2013-05-26
posted: 116
promoted:
bookmarked:
杭州
4subject: 問題已解決Promote 0 Bookmark 02022-08-09quote  

大大上面的文字我是讀不太懂。

以下是我解決問題的過程:

在命令行輸入xinput,提示「running xinput against an Xwayland server」,也就是說,從ubuntu某個版本開始,鍵盤輸入機制發生改變。

ibus跟上了這個改動,而gcin沒有跟上。

wayland或許能使輸入設備響應更快,或者對編程人員調用api更方便。但是對用戶而言,好像不太方便。因此我要禁用它。

網上搜索「disable wayland ubuntu 22.04」,則得到相關文章。具體改動位置是:

/etc/gdm3/custom.conf

進去把WaylandEnable=true改成false保存重啟即可。

之後gcin就可以正常安裝使用了。

eliu

joined: 2007-08-09
posted: 11444
promoted: 617
bookmarked: 187
新竹, 台灣
5subject: 問題已解決Promote 0 Bookmark 02022-08-09quote  

e201302012123@g

網上搜索「disable wayland ubuntu 22.04」,則得到相關文章。具體改動位置是:

/etc/gdm3/custom.conf

進去把WaylandEnable=true改成false保存重啟即可。

之後gcin就可以正常安裝使用了。

原來如此,看來是GTK 用了 Wayland 後,就造成 X11 的不相容。感謝回報。

QT還是用X11。XIM 是用 X11,輸入法只用 Wayland 就沒辦法用了。目前 java 還是用XIM,Android Studio 就沒辦法用?

如果 gcin 只用 GTK,會有些功能沒辦法使用,因為 GTK 沒有包含所有 X11 的功能。

edited: 6

cht電腦資訊gcin
adm Find login register
views:1216