cht電腦資訊Linux
adm Find login register

debian 安裝軟體的相依性真奇怪

alan

joined: 2007-09-25
posted: 134
promoted: 7
bookmarked: 1
1subject: debian 安裝軟體的相依性真奇怪Promote 0 Bookmark 02011-10-14quote  

想裝個 gdm3試試看。會要我安裝這麼多:

brasero{a} gdm3 gnome-desktop3-data{a} gnome-power-manager{a} gnome-session-bin{a} gnome-settings-daemon{a} gstreamer0.10-pulseaudio{a} gvfs-backends{a} libasound2-plugins{a} libbluetooth3{a} libbrasero-media3-1{a} libcairo-perl{a} libcdio-cdda0{a} libcdio-paranoia0{a} libexempi3{a} libglib-perl{a} libgnome-desktop-3-0{a} libgnomekbd7{a} libgphoto2-2{a} libgphoto2-l10n{a} libgphoto2-port0{a} libgtk2-perl{a} libnautilus-extension1a{a} libpackagekit-glib2-14{a} libpango-perl{a} libpulse-mainloop-glib0{a} nautilus{a} nautilus-data{a} pulseaudio{a} pulseaudio-esound-compat{a} pulseaudio-module-x11{a} pulseaudio-utils{a} python-software-properties{a} rtkit{a} software-properties-gtk{a} synaptic{a} unattended-upgrades{a}

有夠可怕!

eliu

joined: 2007-08-09
posted: 11420
promoted: 616
bookmarked: 186
新竹, 台灣
2subject: Promote 0 Bookmark 02011-10-15quote  

Mandriva 有時候也會。gdm 與 brasero 光碟燒錄軟體扯在一塊就有點太扯了。

有 brasero 的原因應該是你原本就有安裝了,因為 gnome 的相關 package 需要 update,連帶造成 brasero 也需要 update

edited: 1
Tetralet

joined: 2007-11-27
posted: 255
promoted: 35
bookmarked: 13
3subject: Promote 0 Bookmark 02011-10-15quote  

請在 /etc/apt/apt.conf 中加入一行

APT::Install-Recommends 0;

試試,應該可以少裝非常多套件。

edited: 1
alan

joined: 2007-09-25
posted: 134
promoted: 7
bookmarked: 1
4subject: Promote 0 Bookmark 02011-10-15quote  

0 個套件升級, 37 個新安裝。好吧,裝就裝,呵。

最近太忙,好一陣子沒跟linux 的資訊。就懶得去管,穩定用就好。

我覺得啦,linux 的桌面還是比較適合熱血的硬派份子。

哈,熱血硬派,沒錯,就透露出我老了。 不然一直想改成arch linux

更糟的是,lightdm是壞的,不裝gdm3 我家人還不會登入。

alan

joined: 2007-09-25
posted: 134
promoted: 7
bookmarked: 1
5subject: Promote 0 Bookmark 02011-10-15quote  

Tetralet:

原來有這個功能,我來試試看!

alan

joined: 2007-09-25
posted: 134
promoted: 7
bookmarked: 1
6subject: Promote 0 Bookmark 02011-10-15quote  

我抱怨的太早,是我自己沒搞精楚,Recommends 0 就解決我的問題。

呵。感謝!

alan

joined: 2007-09-25
posted: 134
promoted: 7
bookmarked: 1
7subject: Promote 0 Bookmark 02011-10-15quote  

原來有這個選項!

$ aptitude -R install gdm3

$ apt-get --no-install-recommends install gdm3

coolcd
joined: 2008-01-21
posted: 2596
promoted: 348
bookmarked: 95
8subject: Promote 0 Bookmark 02011-10-15quote  

我是在 aptitude 文字介面的「選項」調整

在 「選項--\處理相依關係」 裡有「自動安裝推薦的套件」,預設會打勾

 

eliu

joined: 2007-08-09
posted: 11420
promoted: 616
bookmarked: 186
新竹, 台灣
9subject: Promote 0 Bookmark 02011-10-15quote  

如果該 update 的沒 update,不知道會不會造成問題?

Tetralet

joined: 2007-11-27
posted: 255
promoted: 35
bookmarked: 13
10subject: Promote 0 Bookmark 02011-10-15quote  

eliu

如果該 update 的沒 update,不知道會不會造成問題?

是還好,Debian 套件在升降級及處理意外狀況方面算蠻強的。

前題是套件維護者有用心的話 XD

cht電腦資訊Linux
adm Find login register
views:14824