cht電腦資訊gcingcin分享
adm Find login register

關於gcin-2.8.8在qt5的環境中編譯的問題

guest
1 關於gcin-2.8.8在qt5的環境中編譯的問題
Promote 0 Bookmark 02019-02-26quote  

作業環境 Linux 4.19.23-gentoo #1 SMP x86_64

桌面        LXQT

QT版本   5.11.3

gcin版本  2.8.8

個人在將gcin-2.8.8的qt5-im/Makefile做了以下patch後,gcin就能正常的使用在qt5的環境

sed -i 's/Qt5Core Qt5Gui/Qt5Core Qt5Gui Qt5DBus/g' "${S}"/qt5-im/Makefile

 

後來檢視了qt5-im/Makefile後發現

第6行

INCS=-I../im-client -I/usr/include/X11 `pkg-config Qt5Core Qt5Gui --cflags`

第16行

LDFLAGS=-L../im-client -lgcin-im-client `pkg-config Qt5Core Qt5Gui --lib`

都少了Qt5DBus

經過修正就可以正確執行在qt5的環境了

eliu
2
Promote 0 Bookmark 02019-02-28quote  

cht電腦資訊gcingcin分享
adm Find login register
views:5398