cht台灣個人LGJ
adm Find login register

zenwalk 6.0 has been released !

本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
1subject: zenwalk 6.0 has been released !Promote 0 Bookmark 02009-03-11quote  

用 zenwalk 用到現在,小毛病不是沒有,但整體運作還算是順利,而且這是一 rolling released distro,我可以安裝一次就一直用到底,就是可以一直 upgrade 升級,無需重安裝。我曾 upgrade 一次,過程還算順利(有點自行設定上的小問題,這需要自行解決),不過可能由於工具是 bash 寫的,所以覺得有點慢。

在我的 vista 還沒玩厭之前,可能還是會繼續使用 zenwalk。因為 freebsd 裝不進 vbox,等看 vbox 新版本看會不會有改進,不想現在就直接裝在實體機器上。

Zenwalk 6.0 has been released !

- Kernel 2.6.28.7 with gspca (supports many USB webcams)
- The new XFCE 4.6
- Openoffice 3.0.1 replaces Gnome Office as the main productivity suite
- Wicd becomes the main network configuration tool
- New Zenpanel with integrated Disk Manager, Wifi and Wired Network Manager
- Gksu keyring based desktop granting system
- Faster boot (tuned init scripts, with realtime I/O scheduler)
- PAM authentication has been added to the system
- Improved suspend/hibernate, with XFCE Power Manager
- new Netpkg with orphan dependencies and "offline operation" support
- The powerful Exaile juke-box stream player has been added
- New artwork
- A simplified installer

不過,我實在是用不慣 XFCE,所以現在仍然用的是 GNOME(由於記憶體夠,CPU 速度也夠,現在也不用 icewm 了)。


edited: 1
本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
2subject: Promote 0 Bookmark 02009-03-11quote  

有一個缺點就是國內沒有 mirror 站,連外慢到暴,我一整個晚上才 upgrade 好,但在另一個 mirror 站又發現版本比我原來用的 mirror 站新,又更新了一遍。@_@

現在進不了 X,晚上再來看是怎麼一回事。

怪不得有人會說,重裝有時候是最快的。


本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
3subject: Promote 0 Bookmark 02009-03-11quote  

LGJ
現在進不了 X,晚上再來看是怎麼一回事。

怪事,我又碰到以前常常碰到的問題。nvidia 顯示卡,X 所附的 driver 常常會說找不到螢幕(No screens found),但只要你換成 nvidia 官方的 driver 就找得到了。沒想到這個問題一直都沒解決(xorg 7.4)。


edited: 1
本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
4subject: Promote 0 Bookmark 02009-03-11quote  

我從 5.2 upgrade 到 5.4 很順利,但由 5.4 到 6.0 就失敗了,主要是出在 X。初步檢查是因為 X 的套件新舊混在一起了。應該是 mirror 站和本站沒有同步的關係。

這種情形下,重裝是最快的。找了一下下載點,台灣沒有人 mi 回來。最近連外慢到爆。Orz


edited: 1
本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
5subject: Promote 0 Bookmark 02009-03-11quote  

LGJ
我從 5.2 upgrade 到 5.4 很順利,但由 5.4 到 6.0 就失敗了,主要是出在 X。初步檢查是因為 X 的套件新舊混在一起了。應該是 mirror 站和本站沒有同步的關係。

更正一下。

upgrade 到 6.0 也是正常的,後來會發生問題是,我把來源修改至 snapshot,所以,新舊套件混在一起你儂我儂了。Orz


本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
6subject: Promote 0 Bookmark 02009-03-12quote  

我下載了 6.0 iso 來試裝,的確是會有問題,問題應該就是 nvidia driver 不能用 Xorg 的。怪的是,5.2/5.4 就沒問題。

我還是來裝 MDV one 好了,看最近的 MDV 有沒有長進,至少他有 GNOME 專版。


本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
7subject: Promote 0 Bookmark 02009-03-13quote  

氣死我了,搞了半天,原來 logic partition 是不能當 BIOS boot partition 的?害我裝了半天。@_@

最後還是決定把 linux/bsd 裝到實體機器去,Vista 用到現在也只是備用,根本沒用過幾天。看來起多重開機碰到 vista 這怪物會有點問題,暫時先把 grub/lilo 裝到 root partition 去。


本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
8subject: Promote 0 Bookmark 02009-03-13quote  
有一段時間沒有用 linux,忘了以前是不是也這樣。編 kernel 用的 gcc 版本是要和編 modules 的 gcc 版本一樣才行?


dou0228
joined: 2008-08-14
posted: 21
promoted: 2
bookmarked: 2
9subject: Promote 0 Bookmark 12009-03-13quote  

LGJ
有一段時間沒有用 linux,忘了以前是不是也這樣。編 kernel 用的 gcc 版本是要和編 modules 的 gcc 版本一樣才行?

2.6 的 kernel 有一個 vermagic 裡面有紀錄 gcc version 大笑

eliu

joined: 2007-08-09
posted: 11381
promoted: 614
bookmarked: 186
新竹, 台灣
10subject: Promote 0 Bookmark 02009-03-13quote  

編 kernel 用的 gcc 版本是要和編 modules 的 gcc 版本一樣才行?

在 compile nvidia 的 driver? 

edited: 1
本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
11subject: Promote 0 Bookmark 02009-03-13quote  
"eliu"
在 compile nvidia 的 driver?

Yes. Nvidia say I have a kernel compile with gcc 4.2 but my system's gcc is 4.3. And I compile with gcc 4.3 cannot load by kernel, so I used vesa now.

It seems that hyperrate's post editor cannot support Konqueror very well.

I'm on my Slax Linux box(live cd) and cannot input chinese now.


edited: 1
本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
12subject: Promote 0 Bookmark 02009-03-13quote  

啊,我的英文現在倒退到老外看不懂的程度。吐舌頭

  1. Nvidia driver 編不起來,暫時用 vesa 頂著。
  2. FreeBSD 7.1 抓不到我的 SATA HD 及 CD/DVD rom,所以無法安裝,真奇怪,不知道為什麼抓不到,聽大神們都說有支援。
  3. 我用 Slax Live CD 測試了一下,除了 nvidia driver 要用vesa 來代替外,其他網卡、SATA/IDE 硬碟,CD/DVD rom,音效卡都 OK。因此可以考慮裝進實體機器了。
等有空再來繼續玩。


Solomon

joined: 2008-02-27
posted: 78
promoted: 22
bookmarked: 3
13subject: Promote 0 Bookmark 02009-03-13quote  
LGJ

Yes. Nvidia say I have a kernel compile with gcc 4.2 but my system's gcc is 4.3. And I compile with gcc 4.3 cannot load by kernel, so I used vesa now.

It seems that hyperrate's post editor cannot support Konqueror very well.

I'm on my Slax Linux box(live cd) and cannot input chinese now.

如果系統還有 gcc-4.2 的話,直接 CC=gcc-4.2 sh NVIDIA-XXXXXX.run 就可以了。沒有的話我的做法會變成拿source用4.3重新編一次。之後就沒問題了。

本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
14subject: Promote 0 Bookmark 02009-03-13quote  

Solomon
如果系統還有 gcc-4.2 的話,直接 CC=gcc-4.2 sh NVIDIA-XXXXXX.run 就可以了。沒有的話我的做法會變成拿source用4.3重新編一次。之後就沒問題了。

由於 zenwalk 我完全是拿來用,並不算熟悉,我一開始也想說是不是還有另一個版本的 gcc,結果是沒有。然後用 gcc43 重編 kernel 後,nvidia 還是告訴我 kernel 是 4.2 編的(重開機後)。@_@

要重檢查一下 build sh 及 zenwalk 的 kernel source code 內容。不知道是不是我的機器太好了,編 kernl 竟然幾分鉉就編好了?XD

我是有印象有某一段黑暗時期,編 kernel 要用特定版本的 gcc。


本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
15subject: Promote 1 Bookmark 02009-03-16quote  

最後還是安裝回 ZenWalk 5.2 並升級至 6.0,但是 kernel 及 xorg 不升級,原因是 VBox 2.1.0 目前似乎無法完全支援 2.6.28 的新 kernel,對 xorg 7.4 的支援也不行(我的 VBox 是安裝在 Vista)。vboxsf 及 vboxvideo 這兩個模組無法使用。

在這個過程中,我試著安裝 Slax 及 ArchLinux,兩個都不錯,但是要說到安裝流程的簡便,還是 ZenWalk 的設計較簡單方便,幾乎是一直線的流程裝到底,安裝完成的時間最短(是短很多,可能是因為「分叉流程」少的關係?),安裝好後,幾乎不需要什麼設定就能使用,頂多是裝個中文字型及中文輸入法,而 ZenWalk 是一個預設給開發者使用的簡便 distro,無需另外安裝額外的東西就可以編譯程式。

愈來愈懶的人,例如我,安裝 ZenWalk 很適合。裝好馬上就能用,安裝完大概需要 2.1 GB 的空間,安裝時間沒認真計算,大概十幾到二十分鐘的樣子。


edited: 3
本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
16subject: Promote 0 Bookmark 02009-03-15quote  

我試過最新的 VBox 2.1.4,還是不行,不知道為什麼,無法正確產生所需要的 X video modules,因此進 X 無法使用 vboxvideo,會改去使用 vesa,結果就是一片黑。

BTW,升級 VBox 後,原來能用的 ZenWalk 仍然可以使用,VBox 會自動轉換 image 成為新格式。


CC: Linux
cht台灣個人LGJ
adm Find login register
views:23355