cht電腦資訊gcin
adm Find login register

gcin 無法在 kate (15.04.3-1 & 15.08.0 )上打字

maxwux
joined: 2011-09-12
posted: 28
promoted:
bookmarked:
1subject: gcin 無法在 kate (15.04.3-1 & 15.08.0 )上打字Promote 0 Bookmark 02015-08-26quote  

gcin 無法在 kate (15.04.3-1 & 15.08.0 )上打字

我不確定是 kate 還是 gcin 還是 arch 打包的關係造成的

不知道該如何修正這個問題....... :(

eliu

joined: 2007-08-09
posted: 11283
promoted: 612
bookmarked: 185
新竹, 台灣
2subject: Promote 0 Bookmark 02015-08-26quote  

好像是 qt5 的部份打包有問題?

maxwux
joined: 2011-09-12
posted: 28
promoted:
bookmarked:
3subject: Promote 0 Bookmark 02015-09-11quote  

請問我該怎麼檢查這個問題呢?

現在連 dolphin (15.08.0) 也不能使用 gcin 了..... 暈倒

felixonmars
joined: 2015-09-11
posted: 3
promoted:
bookmarked:
Wuhan, China
4subject: Promote 0 Bookmark 02015-09-11quote  

手做了一个 patch:

diff --git a/qt5-im/gcin-qt5.h.org b/qt5-im/gcin-qt5.h
index 63aacc0..a72ea76 100644
--- a/qt5-im/gcin-qt5.h.orig
+++ b/qt5-im/gcin-qt5.h
@@ -9,7 +9,7 @@ class QGcinPlatformInputContextPlugin : public QPlatformInputContextPlugin
 {
     Q_OBJECT
 public:
-    Q_PLUGIN_METADATA(IID "org.qt-project.Qt.QPlatformInputContextFactoryInterface" FILE "gcin.json")
+    Q_PLUGIN_METADATA(IID "org.qt-project.Qt.QPlatformInputContextFactoryInterface.5.1" FILE "gcin.json")
     QStringList keys() const;
     QGcinPlatformInputContext *create(const QString& system, const QStringList& paramList);
 };

本想用 QPlatformInputContextFactoryInterface_iid 这个 macro,奈何编译时挂在了 moc,我也不是很熟悉这一块,所以只好继续硬写成新的 IID 了。

Arch Linux [extra]/gcin 已据此更新至 2.8.3-4。

eliu

joined: 2007-08-09
posted: 11283
promoted: 612
bookmarked: 185
新竹, 台灣
5subject: Promote 0 Bookmark 02015-09-11quote  

Thanks

maxwux
joined: 2011-09-12
posted: 28
promoted:
bookmarked:
6subject: Promote 0 Bookmark 02015-09-11quote  

感謝 felixonmars

問題解決了,真是太棒了

danjiun
joined: 2015-08-05
posted: 17
promoted:
bookmarked:
7subject: Promote 0 Bookmark 02015-09-11quote  

Hi Eliu.

很好現在可以決定就是這個問題。你可以幫我寄一個gcin-plugin 新版給Qt5 嗎?

除非我需要compile, 可是./configure 還是找不到我Qt-libraries, 可能是一個不標準的位子. 你也可以告訴我要放到哪裡或是是不是要set 一個environment variable. ldd 全部會找到,比防 :

daniel@PANDA:~/chino$ ldd ./VocabularyMem
    linux-vdso.so.1 =>  (0x00007ffd337bf000)
    libQt5MultimediaWidgets.so.5 => /opt/Qt/5.5/gcc_64/lib/libQt5MultimediaWidgets.so.5 (0x00007f7f9b079000)
    libQt5Multimedia.so.5 => /opt/Qt/5.5/gcc_64/lib/libQt5Multimedia.so.5 (0x00007f7f9ad95000)
    libQt5Widgets.so.5 => /opt/Qt/5.5/gcc_64/lib/libQt5Widgets.so.5 (0x00007f7f9a517000)
    libQt5Gui.so.5 => /opt/Qt/5.5/gcc_64/lib/libQt5Gui.so.5 (0x00007f7f99d04000)
    libQt5Network.so.5 => /opt/Qt/5.5/gcc_64/lib/libQt5Network.so.5 (0x00007f7f999aa000)
    libQt5Core.so.5 => /opt/Qt/5.5/gcc_64/lib/libQt5Core.so.5 (0x00007f7f99265000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f7f99024000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f7f98ca7000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f7f989a1000)
...

謝謝任何的幫忙. Daniel

eliu

joined: 2007-08-09
posted: 11283
promoted: 612
bookmarked: 185
新竹, 台灣
8subject: Promote 0 Bookmark 02015-09-11quote  

寫個 一個一般的 app 應該是不需要 compile gcin 吧!im-gcin.so 是 qt load 進來的,所以 ldd 是看不到的。先讓用 qt5 的 app如 kate 可以使用gcin 再說。

danjiun
joined: 2015-08-05
posted: 17
promoted:
bookmarked:
9subject: Promote 0 Bookmark 02015-09-11quote  

Hi

可是我需要一個新版的plugin :

libgcinplatforminputcontextplugin.so

可以放到 .../plugins/platforminputcontexts

怎麼弄?

eliu

joined: 2007-08-09
posted: 11283
promoted: 612
bookmarked: 185
新竹, 台灣
10subject: Promote 0 Bookmark 02015-09-12quote  

Ubuntu 不是有我 compile 好的版本嗎?為什麼要自己 compile 呢?

danjiun
joined: 2015-08-05
posted: 17
promoted:
bookmarked:
11subject: Promote 0 Bookmark 02015-09-13quote  

Hi

不好意思,可是你compiled plugin 上個9月11日寄到Arch Linux, 我還是沒有成功。所以我要試試compile.

我還不能用gcin 在 Qt5 程式. Frown. 我花很多天很多個小時(15?) 可是我快要放棄。可能要等到你放新的版本到

deb http://hyperrate.com/gcin-ubuntu1504 eliu release

Daniel

guest
12subject: Promote 0 Bookmark 02015-11-15quote  

請教同一問題

IID需要如何硬寫

我在4.09gentoo上 qtcore-5.5.1的版本,編譯2.8.4版gcin

不管是用以下的哪個

org.qt-project.Qt.QPlatformInputContextFactoryInterface

org.qt-project.Qt.QPlatformInputContextFactoryInterface5.1

org.qt-project.Qt.QPlatformInputContextFactoryInterface5.5

在kate-15.08.1上面都是無法Keyin中文

是我IID使用錯了嗎。

guest
13subject: Promote 0 Bookmark 02015-11-21quote  

danjiun

Hi

不好意思,可是你compiled plugin 上個9月11日寄到Arch Linux, 我還是沒有成功。所以我要試試compile.

我還不能用gcin 在 Qt5 程式. Frown. 我花很多天很多個小時(15?) 可是我快要放棄。可能要等到你放新的版本到

deb http://hyperrate.com/gcin-ubuntu1504 eliu release

Daniel

 

我在另一棟樓看到有人說已經嘗試成功了,請參看http://hyperrate.com/thread.php?tid=31956#31956

cht電腦資訊gcin
adm Find login register
views:13746