cht電腦資訊Linux
adm Find login register

G5 quad core + nvidia quadro fx4500 + debian 8.2 ppc port 開機狀況

IanHo
joined: 2010-08-28
posted: 394
promoted: 7
bookmarked: 4
Taipei
1subject: G5 quad core + nvidia quadro fx4500 + debian 8.2 ppc port 開機狀況Promote 0 Bookmark 02015-10-30quote  

老梗問題再問一次,有問有機會:
軟硬體環境是PowerMac G5 quad core 2.5Ghz + nvidia quadro fx4500顯卡(apple官方規格內) + debian 8.2 PowerPC Port 安裝光碟。
依照預設值安裝流程,重開機,跑完一堆純文字的系統啟動流程之後,最後就是出現螢幕畫面一整片雪花,然後就沒有反應了。
試了許多關鍵字,網路上的東西我"看沒有"(全部只有英文),出現關鍵字linux kernel不相容或知支援之類的字眼吧?
然後我突發奇想,於是重灌,這次我在"結束安裝"步驟之前,進入aptitude,
然後額外選擇安裝
linux-headers-4.2.0-0.bpo.1-powerpc64
linux-image-4.2.0-0.bpo.1-powerpc64
這兩個套件,重開機,跑一堆純文字的系統啟動流程,然後在
fb: switching to nouveaufb from OFfb NVDA,Displ
這一行停住了,沒有反應了,卡死了~~~
我把這一行拿去google,"看沒有"。
這一行到底是怎麼一回事???
有沒有什麼解法,例如在"結束安裝"步驟之前,進入shell,
在後在某個絕對路徑下的某個參數設定檔內的某個段落內增補或修改某行字串內容,可以解決開機流程的這ㄧ行所發生的狀況???

----以下簽名檔------------------------------------------------------------

發表過的網路文字作品;

https://sites.google.com/site/ianho7979/home

IanHo
joined: 2010-08-28
posted: 394
promoted: 7
bookmarked: 4
Taipei
2subject: Promote 0 Bookmark 02015-10-31quote  

災難不斷。網路上看到一些關鍵字 nouveau.modeset=0,於是再做嘗試。
debian 8.2系統安裝過程,我的分割區設定成這樣:
sda
#1 32.3kB apple
#2 1.0MB B K 啟動 YaBoot (用途:NewWorld的啟動分割區,可開機設定:開)
#3 50.0GB B Ext4 SYSTEM /(可開機設定:開)
#4 83.0GB Ext4 DATA /media/data
#5 17.0GB swap swap swap
57.9kB 未使用空間

系統步驟尾端,我進入shell。
nano /etc/yaboot.conf
內容修改如下,##內容是原始內容。

boot=/dev/sda2
## boot="/dev/disk/by-id/ata-WDC_WD1500HLFS-01G6U3_WD-WXL209033989-part2"
device=/ht@0,f2000000/pci@9/k2-sata-root@c/ffffffffffffffff/@0
partition=3
root=/dev/sda3
## root="UUID=7c5a63c1-20de-424b-9205-e1c4dad59de0"
timeout=50
install=/usr/lib/yaboot/yaboot
magicboot=/usr/lib/yaboot/ofboot
enablecdboot

image=/boot/vmlinux
label=Linux4.2
read-only
initrd=/boot/initrd.img
append="nouveau.modeset=0"

image=/boot/vmlinux-3.16.0-4-powerpc64
label=Linux3.16
read-only
initrd=/boot/initrd.img-3.16.0-4-powerpc64
append="nouveau.modeset=0"

編輯存檔之後,執行 ybin -v 回饋訊息如下:
ybin: finding openfirmware device path to '/dev/sda2'...
ofpath: /proc/device-tree does not exist
ofpath: make sure you compiled your kernel with config_proc_devicetree=y
ybin: unable to find openfirmware path for boot=/dev/sda2
ybin: please add ofboot=<path> where <path> is the openfirmware path to /dev/sda2 to /etc/yaboot.conf
看沒有,google不出所以然來。
感覺沒完沒了~~~
但我相信其實"早就有了"相關設定步驟流程。
例如yaboot.conf該再補些什麼字串才會正確之類的。
只是不曉得藏在網路上的哪裡,我搜尋能力有限所以找不到。

----以下簽名檔------------------------------------------------------------

發表過的網路文字作品;

https://sites.google.com/site/ianho7979/home

IanHo
joined: 2010-08-28
posted: 394
promoted: 7
bookmarked: 4
Taipei
3subject: Promote 0 Bookmark 02015-11-01quote  

繼續的狀況:
重慣系統,又有看到一些關鍵字,然後嘗試將作法改成:
一預設值一路裝到最後,結束安裝之前,進入shell,在aptitude補安裝:
vmlinux-4.2.0-0.bpo.1-powerpc64
initrd.img-4.2.0-0.bpo.1-powerpc64
然後用nano編輯器,將 /etc/modprobe.d/modesetting.conf 新增一行
options nouveau modeset=0
存檔。繼續,完成安裝流程
重開機,系統開始跑一長串字串的開機流程,
沒有出現
fb: switching to nouveaufb from OFfb NVDA,Displ
字串了(或著說跑太快了我也來不及看)。
跑一跑字串,畫面變成一片黑,又是什麼都沒有了。
到底該再增補設定些什麼???可以解決這個問題???

----以下簽名檔------------------------------------------------------------

發表過的網路文字作品;

https://sites.google.com/site/ianho7979/home

IanHo
joined: 2010-08-28
posted: 394
promoted: 7
bookmarked: 4
Taipei
4subject: Promote 0 Bookmark 02015-11-04quote  

繼續的狀況2:
系統安裝的階段,結束安裝之前,我進入shell,
/etc/modprobe.d/modesetting.conf 新增一行
options nouveau noaccel=1
開機流程在
broadcom 43xx driver loaded [features: pmnls]
這一行卡住了當掉了,於是我重灌,
然後於aptitude補安裝firmware-b43-installer套件。
開機流程的字串,原本的
fb: switching to nouveaufb from OFfb NVDA,Displ
終於掠過了。
可是在以下這行出現之後,又卡住了當掉了。
b43-phy0: broadcom 4318 wlan found (core revision 9)
這又是怎麼回事了???
我google不出所以然來。

----以下簽名檔------------------------------------------------------------

發表過的網路文字作品;

https://sites.google.com/site/ianho7979/home

cht電腦資訊Linux
adm Find login register
views:4095