cht電腦資訊gcin
adm Find login register

make gcin 2.8.3 的時候出現錯誤

maxwux
joined: 2011-09-12
posted: 28
promoted:
bookmarked:
1subject: make gcin 2.8.3 的時候出現錯誤Promote 0 Bookmark 02015-07-21quote  

In file included from moc_qgcinplatforminputcontext.cpp:9:0:
qgcinplatforminputcontext.h:3:39: 嚴重錯誤:qpa/qplatforminputcontext.h:沒有此一檔案或目錄
編譯插斷。
<builtin>: recipe for target 'moc_qgcinplatforminputcontext.o' failed
make[1]: *** [moc_qgcinplatforminputcontext.o] Error 1
make[1]: *** Waiting for unfinished jobs....
In file included from moc_gcin-qt5.cpp:9:0:
gcin-qt5.h:3:47: 嚴重錯誤:qpa/qplatforminputcontextplugin_p.h:沒有此一檔案或目錄
編譯插斷。
<builtin>: recipe for target 'moc_gcin-qt5.o' failed
make[1]: *** [moc_gcin-qt5.o] Error 1
In file included from gcin-qt5.cpp:2:0:
gcin-qt5.h:3:47: 嚴重錯誤:qpa/qplatforminputcontextplugin_p.h:沒有此一檔案或目錄
編譯插斷。
<builtin>: recipe for target 'gcin-qt5.o' failed
make[1]: *** [gcin-qt5.o] Error 1
In file included from gcin-imcontext-qt5.cpp:26:0:
qgcinplatforminputcontext.h:3:39: 嚴重錯誤:qpa/qplatforminputcontext.h:沒有此一檔案或目錄
編譯插斷。
<builtin>: recipe for target 'gcin-imcontext-qt5.o' failed
make[1]: *** [gcin-imcontext-qt5.o] Error 1
make[1]: Leaving directory '/scratch/gcin-2.8.3/qt5-im'
Makefile:102: recipe for target 'all' failed
make: *** [all] Error 2

請問是否我還缺少什麼嗎?

OS: Arch Linux

 

./configure
prefix: /usr/local
.... Testing gtk+-2.0 : found
gtk+-2.0 will be used.
GTKINC: -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/harfbuzz -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/harfbuzz
GTKLDFLAGS: -lgtk-x11-2.0 -lgdk-x11-2.0 -lpangocairo-1.0 -latk-1.0 -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lglib-2.0 -lfontconfig -lfreetype
.... Testing indicator(Ubuntu)    :  Not found. It's ok if you don't want indicator support.
.... Testing anthy    :  found.
testing if you have qt3 support
-> Yes, but disabled.
testing if you have qt4 support
-> Yes, you have Qt4 support.
testing if you have qt5 support
-> Yes, you have Qt5 support.
testing if you have GTK+ 3.x support
-> Yes, you have GTK+ 3.x support.
Y
QT4_MOC=/usr/lib/qt4/bin/moc
QT5_MOC=/usr/bin/moc

edited: 2
eliu

joined: 2007-08-09
posted: 11262
promoted: 612
bookmarked: 185
新竹, 台灣
2subject: Promote 0 Bookmark 02015-07-21quote  

Ubuntu 需要 install qtbase5-private-dev. 不清楚 arch linux 是在那一個 package

maxwux
joined: 2011-09-12
posted: 28
promoted:
bookmarked:
3subject: Promote 0 Bookmark 02015-07-21quote  

thanks.

我找找看

joe
joined: 2015-06-30
posted: 6
promoted:
bookmarked:
HK
4subject: Promote 0 Bookmark 02015-08-01quote  

Archlinux 有自己安裝包 , 為甚麼要自己 make ?

pacman -S gcin

cht電腦資訊gcin
adm Find login register
views:4809