cht電腦資訊Linux
adm Find login register

技嘉 GIGABYTE GA-Z97-HD3 vs Ubuntu 14.04 音效卡雜音

eliu

joined: 2007-08-09
posted: 11332
promoted: 612
bookmarked: 185
新竹, 台灣
1subject: 技嘉 GIGABYTE GA-Z97-HD3 vs Ubuntu 14.04 音效卡雜音Promote 0 Bookmark 02014-07-13quote  

昨天自己組了一台 PC,主機板是 技嘉 GIGABYTE GA-Z97-HD3,網路…都 OK。

音效卡有聲音,但是會有雜音,音效介面是 Realtek ALC887。google Z97 ALC887,找到暫時的解。

/etc/modprobe.d/fix-sound-intel97.conf 寫入一個 file,內容如下

options snd-hda-intel vid=8086 pid=8ca0 snoop=0

這一行是把 snoop 這個選項關閉,問題就出在 snoop,已經有出 kernel 的 fix 了,或者下一次的 update 就不用把 snoop 關閉了。

還有另外一個問題是,lm-sensors 目前只能抓CPU's,其他的抓不到,好像是國內 ITE 這家公司對 Linux 的支援不好。

edited: 3
guest
2subject: Promote 0 Bookmark 02015-02-02quote  

eliu大有先試過 sensors-detect 了嗎?

我是先用那個指令讓他找對應的 module,之後再用下面的設定檔修正輸出資料,然後幾個 sensor 的別名需要修一下…

http://www.lm-sensors.org/wiki/Configurations/Gigabyte/G33-DS3R

技嘉真的很愛用ITE的晶片,我目前用G31的主機板… IT8718

關於音效卡雜音的部份,以前敝人用 sound blaster live 的經驗是把 buffer 調大一點就解決了

eliu

joined: 2007-08-09
posted: 11332
promoted: 612
bookmarked: 185
新竹, 台灣
3subject: Promote 0 Bookmark 02015-02-02quote  

用 sensors-detect 一樣找不到

FourDollars

joined: 2008-09-25
posted: 6
promoted: 0
bookmarked: 0
台灣台北
4subject: Promote 0 Bookmark 02015-02-03quote  

如果用的是 Ubuntu 可以試試看 ppa:ubuntu-audio-dev/alsa-daily 上面的 oem-audio-hda-daily-dkms

andrew_h
joined: 2015-02-04
posted: 2
promoted:
bookmarked:
5subject: Promote 0 Bookmark 02015-02-16quote  

https://github.com/groeck/it87

try it,順便po一下 dmesg 顯示您是用 ITE 的哪塊晶片

eliu

joined: 2007-08-09
posted: 11332
promoted: 612
bookmarked: 185
新竹, 台灣
6subject: Promote 0 Bookmark 02015-02-16quote  

modprobe 時出現。

sudo modprobe -v it87
insmod /lib/modules/3.13.0-45-generic/kernel/drivers/hwmon/it87.ko
modprobe: ERROR: could not insert 'it87': No such device

dmesg 有

9992.277341] it87: module verification failed: signature and/or  required key missing - tainting kernel

eliu

joined: 2007-08-09
posted: 11332
promoted: 612
bookmarked: 185
新竹, 台灣
7subject: Promote 0 Bookmark 02015-02-17quote  

現在才知道 Ubuntu kernel 已經有 it87,Ubuntu 的 driver 需要 signed 過才能用。上面的 driver install 動作把原本的 it87.ko 幹掉了。重新 update 回原本的 it87.ko 之後, modprobe 仍然 出現 modprobe: ERROR: could not insert 'it87': No such device。

edited: 1

cht電腦資訊Linux
adm Find login register
views:8813