cht電腦資訊gcin
adm Find login register

some questions about gcin ?

guest
1subject: some questions about gcin ?Promote 0 Bookmark 02009-11-23quote  

Hi I am new for Linux. I just installed Fedora 12. I have some questions about gcin and hoepfully some one could help me.

I want to use gcin for chinese iput method but I don't want to change my system language, which gave me a big mess at my terminal last time I tried. I couldn't find any way to restore the defaut language at that time so I just reinstall whole the system again. 

Now I have one question. Does gcin change the system language after install? anyway to keep the defaut system language?

I use "yum install gcin" in Fedora 12, but when I type "ctrl + space" gcin doesn't lauch by itself. I have to type "gcin" in terminal but it still doesn't work for typing chinese characters. 

I have read some articles online but I am not sure where I should put the following lines:

export XMODIFIERS=@im=gcin
export GTK_IM_MODULE=gcin

should I put the above two lines on "/etc/sysconfig/i18n" or ".bash"? 

Could anyone help me with this?

Thanks very much.

eliu

joined: 2007-08-09
posted: 11324
promoted: 612
bookmarked: 185
新竹, 台灣
2subject: some questions about gcin ?Promote 0 Bookmark 02009-11-24quote  
guest
should I put the above two lines on "/etc/sysconfig/i18n" or ".bash"? 

Could anyone help me with this?

Thanks very much.

/etc/sysconfig/i18n or ~/.i18n

caleb
joined: 2007-09-22
posted: 630
promoted: 134
bookmarked: 90
3subject: some questions about gcin ?Promote 0 Bookmark 02009-11-24quote  

guest
Hi I am new for Linux. I just installed Fedora 12. I have some questions about gcin and hoepfully some one could help me.

I believe you may try "im-chooser" in Fedora.

gcin itself may be used in any locales (including C/ POSIX locale).

The most easy way to test your gcin:

1. start a terminal emulator (xterm / gnome-terminal / ...)

2. try commands below:

export GTK_IM_MODULE=gcin

firefox &

3. You may use any GTK+ based applications to replace the "firefox" above.

4. Press Ctrl-Space and you should see gcin icon changes on your system tray

5. For an English setting tool, please run:

LC_ALL=en_US gcin-setup
 

guest
4subject: Thanks a lotPromote 0 Bookmark 02009-11-24quote  

Thank you guys very much. I did put those two lines in "/etc/sysconfig/i18n" before, but it still didn't work, util now I just tried the command "im -chooser" from caleb. It popped out one window where I chose gcin as input method and then suddenly gcin started working since then.... I wasn't even not sure what why very clearly for it. I have never seen this comman when I was looking for the solution for my issue. Now I wonder if this is normal that we need to choose gcin as preferred input method by command "im -chooser" after gcin is installed?

Once again, thanks a lot. Now I finally can enjoy typing chinese characters by my familiar method "注音" in Linux. 謝謝!!^_*

老刀

joined: 2008-11-02
posted: 206
promoted: 17
bookmarked: 9
新北市汐止區
6subject: Promote 0 Bookmark 02009-11-28quote  
I am using Fedora 12, too.  You can visit my blog post about using IM-chooser at http://knife-tw.blogspot.com/2009/11/fedora-12_23.html.

-----

(可能是)現此時唯一用台文所寫的 3C 專題部落格「老刀烏白講」,歡迎你入來交關

 

cht電腦資訊gcin
adm Find login register
views:6664