cht電腦資訊Linux
adm Find login register

vim 的括號 pair 標示

eliu

joined: 2007-08-09
posted: 11333
promoted: 612
bookmarked: 185
新竹, 台灣
1subject: vim 的括號 pair 標示Promote 0 Bookmark 02007-11-22quote  

有沒有人知道為什麼 vim 是移動 cursor 的方式來標示對應的括號,而不是用 反白或顏色的方式,這樣 cursor 跳來跳去,很不習慣。

edited: 1
savage
joined: 2007-09-28
posted: 60
promoted: 2
bookmarked: 1
火星
2subject: Promote 0 Bookmark 02007-11-22quote  

這樣不是比較方便嗎?多多利用 [[ 及 ]] 按鍵(連續快速按)就不必一直在移動 cursor 了。

eliu

joined: 2007-08-09
posted: 11333
promoted: 612
bookmarked: 185
新竹, 台灣
3subject: Promote 0 Bookmark 02007-11-22quote  

可是這樣原來真正的 cursor 的位置就不見了,看起來就跳來跳去的感覺。我覺得實際的位置與相對的括號位置同時顯示比較理想。

本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
4subject: Promote 0 Bookmark 12007-11-22quote  

這個好像是設定的問題?我提供兩張圖,一個是在 xterm,一個是在 gvim。


 


本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
5subject: Promote 0 Bookmark 02007-11-22quote  

忘了寫上設定: $HOME/.vimrc

set cursorline
set showmatch

不知道是不是要這種效果?


eliu

joined: 2007-08-09
posted: 11333
promoted: 612
bookmarked: 185
新竹, 台灣
6subject: Promote 0 Bookmark 02007-11-22quote  

我比較希望的是 cursor 的顏色的都不變,因為平常根本不需要看括號的 match,變來變去看起來有點討厭。

本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
7subject: Promote 0 Bookmark 02007-11-22quote  
eliu

我比較希望的是 cursor 的顏色的都不變,因為平常根本不需要看括號的 match,變來變去看起來有點討厭。

set mps=

就是不要那個  matchparen,是要這樣嗎?那些顏色有時候的確有點討厭。


eliu

joined: 2007-08-09
posted: 11333
promoted: 612
bookmarked: 185
新竹, 台灣
8subject: Promote 0 Bookmark 02007-11-23quote  

括號匹配顯示是很有用,但是 cursor 所在的位置不要變色或是不見,在對面的括號用某些顏色顯示。

本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
9subject: Promote 0 Bookmark 02007-11-23quote  
eliu

括號匹配顯示是很有用,但是 cursor 所在的位置不要變色或是不見,在對面的括號用某些顏色顯示。

呵呵,我懂你的意思了,那些顏色可以自行設定,他的顏色 group 名是  MatchParen,例如:

hi MatchParen ctermfg=cyan guifg=DarkCyan ctermbg=black guibg=white

把這行加在 $HOME/.vimrc 就成了。
 


edited: 1
eliu

joined: 2007-08-09
posted: 11333
promoted: 612
bookmarked: 185
新竹, 台灣
10subject: Promote 0 Bookmark 02007-11-30quote  

結果發現 cursor 不見是 urxvt 造成的。

在 gnome-terminal 上正常,可接受。 

本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
11subject: Promote 0 Bookmark 02007-11-30quote  

不知道所謂 cursor 不見是不是因為顏色造成的?我試了一下 urxvt 不會有這種情形:

http://edt1023.sayya.org/tmp/urxvt.png

請注意我在 Xdefault 所有 terminal 的 cursor 是設成黃色的:

*cursorColor:   yellow

使用預設值的話也不會消失。我啟動的方式:

urxvt -fg gray86 -fn "10x20"


eliu

joined: 2007-08-09
posted: 11333
promoted: 612
bookmarked: 185
新竹, 台灣
12subject: Promote 0 Bookmark 02007-11-30quote  

Vim cursor Focus In

Focus in 的情況。黃色的字是 cursor 所在的位置

看起來怪怪的 

 

Vim cursor Focus out

Focus out 的情況

edited: 1
本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
13subject: Promote 0 Bookmark 02007-11-30quote  

奇怪,我使用的是 rxvt-unicode (urxvt) v8.4 - released: 2007-10-27,不會有這種情形:

http://edt1023.sayya.org/tmp/urxvt1.png


eliu

joined: 2007-08-09
posted: 11333
promoted: 612
bookmarked: 185
新竹, 台灣
14subject: Promote 0 Bookmark 02007-11-30quote  

我用  rxvt-unicode-8.7 

 ./configure --enable-xim --with-codesets=zh  --disable-backspace-key --enable-frills

本人已不在此站活動

joined: 2007-09-19
posted: 4946
promoted: 325
bookmarked: 206
歸隱山林
15subject: Promote 0 Bookmark 02007-11-30quote  

咦,的確 urxvt 8.7 會有這個問題,恐怕這是 urxvt 本身的 bug?bug report 吧!微笑


eliu

joined: 2007-08-09
posted: 11333
promoted: 612
bookmarked: 185
新竹, 台灣
16subject: Promote 0 Bookmark 12007-11-30quote  

找到原因了

 ./configure --enable-xim --with-codesets=zh  --disable-backspace-key --enable-frills --with-term=xterm

如果沒有設定, TERM 這個 env 是 rxvt-uicode,這樣 termcap 就會出錯。

當然,在 .bashrc 設定 export TERM=xterm 也可以,只是不喜歡這樣。 

edited: 1

cht電腦資訊Linux
adm Find login register
views:24582